V9.1 (1.0.8) Bugs and Feedback

The uploader said it was three flights. Thank you

I flew both with the same version of the app (newest) and the first mission was about 4 in the after noon and the second at about 11 the next day so the sun wouldn’t be much different. Both days were sunny with no clouds.

Just a suggestion here. Using this over crops, you don’t always have a perfectly clean spot for lift off nor landing. When DD app takes over, the first thing it does is point the camera down. If the pointing of the camera could be delayed till take off, and the point back up before landing. That would help protect the lens from the ground. Maybe say, camera dont change point angle till 20’ up. Then return to pointing forward 20’ before landing.

Just a thought :smile:


Good idea for protecting camera lens. And don’t think it will be difficult to implement. :wink:

I flew with 9.1 today and seemed to work well. I really like the option to vary altitude to something other than the few defaults in previous versions. I would add the suggestion of identifying the distance (in ft) that the borders of the flight area covers. For example I am flying over crops but may not want to fly the entire field. But I know that I want to fly a rectangle section that is 300ft x 500ft. Without this I am taking a guess at where my flight boundaries are and often flying a lot more area than I need to.


After hitting the accept flight button, the new app (v9.1) starts it’s aircraft checklist and states firmware mismatch for the aircraft (DJI Inspire 1). Does this new app support the latest DJI Inspire 1 Firmware (V1.3.0)?

DJI Inspire 1 Firmware 1.3.0
Drone Deploy App version 1.0.8

The new firmware removed some support for accessing the ground station. A lot of users are having trouble with it. We can either use the older firmware or wait for DJI to fix.

Unfortunately when I try to roll back the firmware for the Inspire, it aborts every time due to the firmware on the SD card being older than the current aircraft firmware.

We are going to do some tests tomorrow to see if we can get some consistent steps to roll back

Flight Info:

DD App = V9.1 (1.0.8)
DJI FW = V01.03.20
AC = Phantom 3 Pro
Flight ID: homesteadprecision_Inspire1
Flight Time: 17:02
Weather = Overcast w Light Winds 0-5mph
Altitude = 390 ft.
High Overlap = Yes

Takeoff: As Expected

First flight went very well. However I cannot get the second flight to load. I select the map, select continue, then nothing happens. Even after power cycles on everything.

It would be nice to be able to merge two flights into one.

For the flight planning I liked the ability to just select the alt as for precision level. It was just a simple press of the button on what precision level I was after.

What do you mean when you say nothing happens? So you select continue and the checklist never starts up?

That is correct. The red button with the plane symbol is faded red and the check list does not pop up. I will power cycle everything and still nothing happens. I have two or three flights like that. Where I have flown one flight and can not continue the mission because the check list will not populate. It is not that the checklist fails. I just plain does not pop up. I am trying to determine if it is DD or my tablet. Galaxy Tab 4. Samsung factory rest it. I have done all the updates I can do. I am at a loss of ideas to try.

Hmm. This is pretty weird. Do you have there the name or ID for one of the flights that won’t continue? I’ll check this tomorrow to see if I can reproduce it with that plan.


The same scenario happened to me again today. When I start DD it defaults to High Overlap in the settings cog. Flew first flight of a multi flight mission with High Overlap turned off. Switched batteries. Went into continue previous mission and it redrew my flight path for high overlap. I ended up just creating a new mission to cover the area that was left as I was unable to get the original flight path back. I’m beginning to wonder if this is a specific problem for the tablet (LG Model) I’m using if this is not happening to others.


Chase, look at the flights from August 6&7. Plus July 31 flight. Those are the most recent issues.

I had same thing happen. Afterwards I thought about it and remembered that i forgot to force close the app then restart the mission. I think that will solve your multi flight and second flight problems. If you look on the forum for the spot for multi flight i think it tells you to do that process.

I understand that Lee. I have tried many combinations with no success.

Sure must be something with the latest version of the app. It use to work better

I flew tonight and everything worked perfect. The only thing that is an inconvenience is always having to close out the app and restart it after a battery in the ship has been replaced.

I’ve just installed v9.1 on a Samsung Tablet Pro 8.4 running Android 4.4.2, and DroneDeploy crashes on start. I run the app, and a few seconds after the login screen comes up, the app quits. This happens regardless of whether I am connected to a remote controller or not.

Any advice?