Beta 1.1.7 Bugs and Feedback

Thanks for trying DroneDeploy for Inspire/P3 1.1.3

Please add feedback and bug reports as a reply to this topic.


I flew two missing tonight and the first one completed. On the decent to touchdown the app crashed. When i went into the dashboard to view # of pictures it was 0/0. I restarted the app flew second mission it flew with no problem, but on the landing it was off the lz by 3M. This was the first time I have had an issue with landing being off more than 1M. The other time I noticed is now when it make a turn the aircraft pitches up more aggressively than previous testing. It’s pitching up so much that you can hear the buffet of the blade and my guess is it’s 15-20deg pitch up.

I love the software and it’s solid with a few hiccups, but you guys are making progress. Keep up the good work.



Just flew a single mission.

I wasn’t able to re-fly a previous mission (that had already been completed a week ago), as when I loaded the mission I was not asked if I wanted to start over or not. Just drew the same area and was able to fly just fine.

For a brief moment, as everything was checked off the check list other than waypoints, the app told me something was wrong, but that message went away in a few seconds and the flight went fine.

Yeah I think some of our new checks go past our time limit to tell the user it’s probably taking too long.

I will do a large mission tomorrow. I did a small mission the other day and everything went flawlessly. I used two batteries and continue mission. I will let you know how the large area works.

Flew a quick single flight/high overlap mission. Everything worked flawlessly for flight. Only problem I had was during upload the select directory option returned a directory doesn’t contain pictures from this mission. Verified SD card did contain images from flight which it did. Tried again and received same error. I ended uploading manually.

I just tried to fly tonight with the new DJI Build 1.4.0010 and tried to start the mission. Once I start the seq for start up it get’s to aircraft. I’m set to F, but the app stops and says i’m not in F Mode. Sometimes this happens when you don’t have correct firmware. I get the checkmark for Firmware.

I attempted this numerous times with same result. Note: I did fly last night as stated with the small issues.

Please advise if 1.1.7 is supporting 1.4.00010.


It won’t work with 1.4.0010. I’ve got a version taking off an starting the mission automatically right now but I’m busy testing it to see if anything can go wrong.


Do you have an estimated timeframe on the new . release?


1-2 days max. We always shoot for quicker but testing can sometimes take longer for more difficult changes.

Any updates on your progress?

We are considering releasing an APK on the forum for those that have upgraded to the newest firmware while we implement a better solution.
The current firmware seems to have the following restrictions:

  • Max length of 500m waypoints
  • Max length of 5000m for the entire mission (30-40 acres at 400 feet)
  • Some new errors I haven’t seen before limiting altitude. I saw these with missions around 390 feet
  • Requires us to set the waypoints while the aircraft is in the air. This causes us to sometimes takeoff and then fail to write waypoints due to many possible reasons and sometimes due to just a slightly bad signal.

We have a version that works for smaller maps that aren’t at super high altitudes. We would recommend that everyone stay on the firmware 1.04.006 or 1.04.005 for now since it works with the app and also should work with all of DJI Go’s newest features.

It appears that the newest firmware limits what users that had previous firmwares were allowed to do. We might have a few fixes planned but I wouldn’t want to use 1.04.0010 if I had a choice at the moment.

Thanks for the update it looks like i’m stuck with .0010. Are you in contact with DJI to see why the sdk is so restrictive as that will put a big constraint on apps such as yours. When may we see the new version you spoke about above?

Running 1.1.7 on the v1.4.0010 today for a real small flight (~1ac) at 98ft. The mission upload to my p3 would fail if high overlap was checked. Unchecked, everything was all-green and the mission went flawlessly.

Tried several Maps today - inspire1 with 1.04.006. Twice the app did not recognize that the inspire already started the mission. Also couldn’t start a mission with the high overlap option - it fails transmitting the waypoints/mission.