Beta 1.3.3 Bugs and Feedback

Thanks for trying the DroneDeploy app for Inspire/P3 1.3.3

Please add feedback and bug reports as a reply to this topic.


I noticed the same quality issues and error 404 with the 3D model. I opened a support request with the IDs.

I had troubles getting the software to start on my NEX 7 tablet. I finally went in to the app config, deleted the cache and files. Then it started up.

After the checks completed I hit the green fly button but the copter didn’t take off. I had to reboot the copter, recreate the mission and the next time it launched and did the mission as expected.

I received the normal message that the maps were complete but unfortunately the 3D map leads to 404 error.

I had some major issues with the previous version last week and couldn’t get drone deploy to work at all. Since updating this last Saturday to Beta 1.3.3 I was able to start the mission 5 times in a row. Each time in between I would power cycle everything including the phone. Thank you! I will be testing it out this week! Am running a Moto X with 5.1 Android with inspire 1 running the latest firmware suggested by Drone Deploy.

Ran new version app yesterday…worked every time. huge improvement on the connection form the previous version.
I was switching between offline and online and worked perfectly. Only issue i would like to see changed is when i flew offline and changed the battery i could then ‘continue’ the mission. I couldnt do this in the online version (not major issue as i just redid the mission and there might be a way already i am missing but it would of saved me some time as was on a tight schedule. overall…brilliant guys!

I can’t get 1.3.3 past the camera test! Ever since I started (1.3.1?) I would get a camera error, but did get one successful flight then. Now on 1.3.3 I’ve only gotten one flight with the camera error while multiple other attempts won’t even launch due to a supposed camera failure. Reboot everything, no go. The camera works fine with other apps and even the 2 flights I’ve gotten with DD the camera worked fine while reporting an error.

DD 1.3.3
P3A FW 1.05.00xx beta
Galaxy Note 8 on 4.4.2

Hi @KMatch I had this happen…in dji go app i use manual camera. I switched this to AUTO and did a gimble calibration and then it worked fine. Try it. hope it helps


flying local missions is working again for me with my inspire 1 FW1.05. and DD1.3.3. Connection to dronedeploy needed several tries and restarting the tablet (Android 4.4).

Syncing a mission worked once but never again. Restarting the app or the tablet didn’t help.


Having experienced the issues with the third-party weather service, I took Jono’s advice and updated the drone deploy app. This fixed the problem with drone deploy not updating the area of interest. I was prompted to update my DJI Inspire 1, as I am still on firmware version (although my records indicate it should be

I have been holding off on the DJI firmware update, since there were initial issues. I read on a DJI forum that they recommend updating to version 1.3.x.x prior to updating to version 1.4.x.x. or above.

I have two questions:

Should I upgrade to DJI version 1.3.x.x prior to upgrading to version 1.4 or 1.5?

Should I upgrade to DJI version 1.4.x or version 1.5.x?

Thanks all for the feedback - I’ll pass along to engineering.

@Mary_Wohnrade, I’d recommend the version listed in our Firmware Update Guide (1.5.11)

You will need to update the RC to v1.3, and the Drone to 1.5.11 (listed in the guide above). You can find 1.3 here

@KMatch please let me know if @altitude58’s suggestion works out for you.

@altitude58 - so you’re saying the continue mission worked well in offline mode, but not in online mode? Interesting - I’ll do some tests this side and see if I can figure out why.

Yes @jono ‘offline’ absolutely fine…every time. But the online version , once battery changed there was no option for continue, or the previous flight on the arrows to select. Just had to do a new map

I have been having issues when attempting to update the firmware on my Inspire 1. For whatever reason the new Beta 1.5 firmware will not properly install on the drone and the GO app says I’m running on firmware version

Whenever going through the preflight checklist the Mission Check keeps failing and cites an “Error while setting waypoints.”

Has anyone else had this issue and found a work around?

Inspire 1:
DJI GO: 2.3.0
DD: 1.3.3

Good to know @altitude58, I think @chasemgray has found a potential issue which might be causing that.

@Mary_Wohnrade I would suggest trying to downgrade the Inspire firmware to 1.3 then back up again. We’ve seen it very rarely where the drone doesn’t ‘accept’ the firmware upgrade.

Will the firmware version 1.05 mess up way points, POI and follow me modes in the P3?

No, they will work the same as before.

Thanks for the quick response!

3 flights today with inspire1 FW1.05. and DD1.3.3. on Android 4.4 - flying at least. Still no usable mission sync.

Planning the first mission (with a lot of waypoints) didn’t go through. Failure during sending the flightplan to the aircraft. So I had to split missions. Uploading images now - maybe you can combine the two missions for me. ( 1445513840_DRONEPARTSINSPIRE and 1445515049_DRONEPARTSINSPIRE )

The first mission that went trough, generated a flight log - the next two unfortunately not. Had to switch to manual mode during one landing - the inspire came down at an offset (pretty windy today).

If you need more logs, let me know.

About what time was your flight where your waypoints failed to write? I can look up jose logs to see why.

Hello, i have a problem. I have the app and i got stuck (see image) Can someone help me?
I also says i don’t have the newest version… but i have the newest. also says i have no sd card in the drone… this is incorrect.

This is a screenshot

Drone: phantom 3
Phone: Samsung j5
Country: The Netherlands

Plz help me. contact me: