Beta 1.1.2 Bugs and Feedback

Thanks for trying DroneDeploy for Inspire/P3 1.1.2

Please add feedback and bug reports as a reply to this topic.


I flew a few missions last week in windy conditions and the inspire was quite erratic. It would pitch forward/level/forward/level/forward in almost a rhythm. It made me nervous enough to cancel both flights because I thought it would crash. I imagine it was trying to keep a certain speed with the gusty winds and was over compensating. Wind speed 20mph+

Hi @chasemgray

I tested 1.1.2 with P3X_FW_V01.04.0001.

Nexus 9
7 out 8 attempts failed. All checks passed but Mission check always created an error. All systems had been rebooted multiple times with no difference.

Galaxy SIII
Ok, an older device. DD app froze after WiFi and GPD check and could not pass Firmware check. Unfortunately no flights possible.

Hi Martin,
Could you try some higher flights to see if you still get a mission error?

AC: P3 Pro
FW: 1.04.01
DD: 1.1.2

Wanted to test out the continue mission functionality. Setup map for 145 acre @ 390 ft. with High Overlap off. During system check failed twice on Mission saying Unable to Set Waypoints. Reset AC, Controller and App. Same error on Checklist. Reset AC, Controller, and App. This time a drew a smaller map that could be handled on one battery and checklist passed. Took off and let it fly 90% of flight. It did fly at slower speeds which apparently can be fixed in the newer firmware but didn’t want to put it on until I heard it was stable. Hit Home Button in DD App and the AC attempted to land right where it was which was about 75-100 ft. away from where I took off. I let it descend until I needed to take control to see if it ever corrected itself which it did not. Did notice the camera did point foward again but during upload of images it was still snapping pics when the camera position was changed and during landing.

1.) Checklist would not pass on large map. Unable to Set Waypoints
2.) RTH via DD App attempted to land at current location and not at Home Location
3.) Continued to take pics after RTH initiated.

I think I know something to try. Can put out a quick fix today for that.

@FarmerJuan The RTH landing the drone at its current location instead of the actual Home location is a firmware feature by DJI and not a bug in DD (this is documented in the DJI manual. If the drone is within 80’ of the RTH location the drone will land where it is when RTH is initiated). I had a near miss due to this and wish DJI would remove this feature from the firmware.

I, too, have had the DD mission fail and was able to get around this by creating a smaller survey area even though the area was only 70 acres and a flight altitude of 400’.

Another issue I’ve had is the drone takes off, climbs to altitude and then just hovers there for several minutes before heading towards the first waypoint. After that, the drone flies the mission without any issues.

I think the issue is with uploading larger number of waypoints. We are looking at this now and have emailed DJI. I hope to have a quick fix in.

Thank you for the explanation on RTH as I was unaware of that feature.

Thanks Chase for the quick response. Would you prefer I keep my ship on FW 1.04.01 or do you think we are safe upgrading the newer 1.04.05.

Some users have been using 1.04.05. It will fly a bit faster and someone said the phantom 3 advance was a bit more stable. I’m not sure it changes much else for us. We are going to be upgrading ours today I think to make sure.

1 - Mission check fails

Tested again flights below 20 meters, this time with 1.04.05. No difference. It always fails at ‘Mission’ check.
Flights at 30 meters work fine.

2 - Flight plan through blocked area

Also, if you plan your mission around a tree or a an object you like be left out, the automatic planner eventually plans the route through the area you actually know, that the drone will crash.

3 - Mission can’t be reused
Missions which have been stopped with the F - P switch can not be repeated instantly. App needs to stopped but even then, I could not reuse the same mission again, while being on the field. The previous flight route has been shown with a dotted line within DD.

Flew three successful mission today with the new version. For the first two I re flew areas that were previous missions. It took a few times to get the missions to load properly but once they were correct everything flew with no issues. The third was a new mission and it setup and flew with no problems. Here are some things that I noticed today.

  1. The new firmware for the Phantom 3 fixes the issue with mission speed. The Phantom flew each mission at 22 mph. Also the improvement in the turns has probably gained around a 10% increase in the area you can cover per battery.
  2. I tried to setup a large mission to see how many acres it can cover per flight and I had the same issue as other with it unable to set waypoints.
  3. The Phantom hover time is reduced with the new version.

I flew the Cantley Beans Copy flight today back to back with different camera settings but I could only upload one of the flights. Can you turn it on so I can upload the second flight? Thank you.

What do you mean you can only upload one of the flights? One of them didn’t appear on your dashboard for some reason?

It only gives me an option for one flight on the dashboard. It does not show two Cantley Beans Copy flights. One other thing that I noticed today was that when the drone is done flying the mission and on the way back there is a one to two second lag in the update of the position on the app. This made it difficult one time because I landed the drone at a location away from the home point.

Was it after or before the one that is currently showing on your dashboard?

It looks like it is not showing the first flight. The first one was started at 11:01 and the second was started at 11:19. Thank you.

I don’t know if it is the exact plan your flew, but it seems to be the same area so it should stitch the same. I marked it as flown on your dashboard. I’m not sure how this happened but I think our offline flight changes in the near future should help.

I cannot upload the images to the new flight. I keep getting an upload failure. Thank you.

Looking over the flights I see what has happened. Two of the flights today were over the same field over a thirty minute time frame. The third flight was over a different area across the road from the first flight. On my flight log the new Smart Survey shows the correct flight plan for the last flight but has the previous images from the other flight in it. Can you look at these three and see what has happened. Thank you.