Beta 1.3.1 Bugs and Feedback

Thanks for trying DroneDeploy for Inspire/P3 1.3.1

Please add feedback and bug reports as a reply to this topic.


Hi Chase

great 1.3 is not crashing on my android 4.4 tablet anymore. Unfortunately I’m now stuck in endless “Syncing plans for offline flights”. Restarting and logon/logoff didn’t help. Any ideas how to resolve that?


Pushed a small fix this morning (1.3.1) that may help this. Can you try connecting the drone anyways? It might just be stuck saying syncing but when you connect a drone it will switch.

I updated this morning with the new version and it opened the first time with no issues but when i left Drone Deploy to go to another program on the Shield I cannot reopen Drone Deploy. I am running 5.1.1 on an NVIDIA shield and have had this happen with the last three versions. If you let it sit for a few minutes you can reopen the app but most of the time I will have to restart the tablet. The app also does not show up running apps. Once it is open everything works well and I will try out the offline flight mode this afternoon.

Hi Chase,
In the Play Store only has version 1.3.0.
I installed a few minutes ago.

It’ll probably update in the play store in a but. 1.3.1 just has a few adjustments for offline.

Yeah offline mode! Most of the areas that I go are not connected. Mapping them is a real challenge.

I was able to try out the new version with offline mode this afternoon. I created the flight in the browser and then synced with the tablet. When I got to the field the app came up with no issues and said it was in offline mode and brought my flight up. Phantom took off and flew with no issues. Great work guys this was very clean. The only thing I did see was a way to set the camera not to use auto settings. Is this in the browser or in the app. Thank you and again great work on this feature.

I flew again today with 1.3.1 using it offline and online. The offline worked great again today with no issues starting the mission and taking the images. When I went to a new site and started an online mission everything connected fine but when I drew the box for the flight area it would not create the flight lines. I shut down the app and tried six more times with no luck each time. I then created the flight on my computer and synced it up and was able to fly using the offline function. Do you have any ideas on why it would not create the flight lines. Thank you.

I have an idea about why and we are putting in a fix. I think we are too aggressively cancelling requests when they take a bit of time. So in the field the online mode isn’t working as well. Ideally we also finish the complete version of offline planning so this isn’t even an issue.

i have 3 days traying to use drone deploy and with out sucess, i have the last firmware on the inspire and the last app on my nexus, and the problem is that when i trace or make my route with the points, normaly you see the green lines that are the flight plan but this time when i make the plan or the waypoints i do not get the green lines with the estimated time and an altltud and much less the checklist ? i do not know whats happening, i try on a shield , on a moto x and the same with all this phones.image

i can not make the green lines apear.

Just tried the latest update and like everyone else I’m not stuck in planning mode anymore . But it does fail to launch the mission. I’m also getting an error with the calculated altitude. It inputs in 766 ft. Even tho the altitude in settings is 395 ft. I have to go in and change it every time manually. Even though I get a green checkmark it still game activate the mission just sits there and hovers .

I forgot to say I’m using a phantom 3 pro and a nivida shield.

i have the same problem 766 ft and get stuck on calculatin plan, and when it pass this stage no green lines in my flight plan. and nothing to do.

this is the problem i have.


I flew with the latest beta on the Play store 1.3.3 using a P3 Pro 1.4. It seemed to handle way points much better than in the past and seemed to keep it’s speed up instead of wasting so much time stopping at each one for a period of time. The rendering came out with some issues. All the buildings have very rough corners and when I click 3D model, I get an error saying “Error 404 The page cannot be found”. The flight is the only one that I flew today.


Thanks for the info Matt, good to know. I’ll look into it and see what could be causing that. Could you mail through to with with flight ID?

Sorry again to all who have been having problems with 1.3.1 - our weather providing service (to give bad weather alerts) was causing the planning stage to hang. We’ve fixed the problem with 1.3.3 - please do update your app to get an improved experience.

1 Like