V9.1 (1.0.8) Bugs and Feedback

Thanks for trying V9.1 (1.0.7)!

Please add feedback and bug reports as a reply to this topic.

Thanks,
Chase

Today I’ve tested vV9 (1.0.7) and when trying to change altitude in the App it’s very difficult to get it. I’ve written 50 in meters and when trying to go back it changes to 20m and was impossible to change figure. It would be better to peovide a button for “validate” the input.

Hi antonio,

Did you manage to get it working? It shouldnt be going to 20 unless there is something wrong with the input. It should only do that if you type in something less than 20

I’ll check this a bit more on my device and see if I can reproduce it.

Yes, but from the user point of view it is not easy to set height.
In the end I have removed all the App settings and restart the mission.

This was fixed Antonio. We just released a V9.1. It seemed the conversion between feet and meters was getting messed up on the profile screen for altitude

Thanks. Will test it this morning and inform you

I tested 1.0.8 today and had quite a few issues. I flew with 1.0.5 yesterday and all was great but today I had the following things happen.

This is using an Nvidia Shield.

  1. I had problems connecting to the aircraft. Several power cycles and it finally found my i1. This has never happened.
  2. I attempted my 1st multi battery mission. At 35% battery on the 1st phase I pressed the RTH on the app. Upon landing I had no type of notification from the app that led me to continue the mission but the altitude did remain at the location where I pressed RTH so I thought it might be going back to that point to continue on. I waited a few minutes and no response from the app. I slid into the menu area and found nothing that indicated a partial mission was underway. I powered off the i1, swapped batteries, and the mission just stayed the same. I had no other option but to go to the home screen and open Drone Deploy again. I did not completely close it so I hoped this would wake it up. The previous mission was nowhere to be found. I power cycled everything but the tablet but there was no sign of the mission I had just attempted. I formatted my SD card and did a smaller mission.
  3. The final (only successful) mission I did was a long fairway at a golf course. I was starting the mission about 1000m from the 1st waypoint. When I would move the preset square mission that it drops over you it would leave the green path lines in place. When I built the mission on the golf course the lines would never appear within the polygon but they would stay overhead. After power cycling everything twice I finally got the mission to build over the polygon vs. staying overhead. This happened earlier in the test (during the big mission) so it wasn’t just this time.

Flight Info:

DD App = V9.1
DJI FW = V01.02.0004
AC = Phantom 3 Pro
Flight ID: 1438705546_JONKDICKSONINSPIRE1
Flight Time: 11:15AM CST
Weather = Sunny w Light Winds 0-5mph
Altitude = 300 ft.
High Overlap = No

Takeoff: As Expected

Flight Path: I didn’t notice during flight as they were furthest from me, but it cutoff short on two waypoint corners on the flight path.

Landing: As Expected within 5 feet of takeoff, but needed to land manually as it would have landed on uneven ground.

Map Processing: Failed. Shows only 30% coverage after stitching.

Any thoughts or tips you can give me as to why this failed would be appreciated.

Thanks,
Jon

Looking at this now. Any flight that has a coverage that isn’t 99-100% gets an engineer looking at it to diagnose what went wrong.

It’s possible it didn’t skip that one waypoint. If we didn’t receive any messages for a short period of time it would display it as a straight line between the two spots where we lost and then regained connectivity.

Ok that makes sense.

Multi-Flight/Continue Mission Issues with 9.1

Settings:
FW: 1.002.006
Altitude: 381 ft.
High Overlap: No

First Flight went as expected. Due to long flight path RTH when battery was nearby and just under 30%.

Second Flight: Switched Battery and restarted DD and selected Continue Mission. Received a DJI Firmware Error on checklist. Rebooted. Error again. Removed and Reinserted SD Card this time checklist passed and took off. Didn’t notice till airborn but it appeared DD redrew my flight path for High Overlap. I let flight continue knowing I’d run short on finishing mission and I had a 3rd battery. Rest of flight went as expected.

Third Flight: Same issues as before with Firmware Error. Did same steps as before in order to get Checklist completed. But now noticed map redrew flight path again and only showed what looked like the flight path of my first flight and completely removed my 2nd flight path and what was left of the mission. It started to fly the area covered during my first flight so I aborted and came back to upload what images I had.

On DD website it only showed my first flight path and the return to home from my second flight. During Auto Upload it only selected the images from my first flight but showed that I had done 3 flights. Flight Log helps show what I’m explaining with it redrawing the mission.

Is it hard coded to default the High Overlap to “On” or is there a setting that I’m missing for this?

It shouldn’t try high overlap unless you select it. It also shouldn’t change any of the settings when you do a continue mission. Can you send the link for this flight. I’m going to be working more on some improvements to storing information such as the which waypoints have been flown. It still hasn’t been changed since the initial experimental release. I’ll look at the flight plans/logs to see if we can figure out how to improve this.

I’m not sure what is happening with the firmware check. Do you have a good connection to the drone when trying to initially connect (no obstructions, etc.).

I’ll verify again tomorrow, but my DD has been defaulting to High Overlap on both missions I’ve planned in 9.1 and had to shutoff during planning. To my knowledge I had good connections but it is possible it was limited. No obvious obstructions for connectivity.

The flight still shows as processing. Does this help? planId=55c11b5b2b13750d09277df1 It will be my latest flight.

Map just finished on my latest flight (yesterday). Looks like the images ended up being over exposed.

https://www.dronedeploy.com/app/data?planId=55c100f731ff9a5128cdeba1

Yeah, it looks like the sun was shining off of those areas just right as well. We will be adding a video preview as well as a way to completely disable auto camera settings so you can tell when this is happening and also set your own camera settings to fix it.

1 Like

What might have caused this so I can look to avoid it in the future? I ran the same plan the day before and it looked great.

I’m not sure. I checked out the exif data and it looks fine. Did you run it at the exact same time of day? Do you remember which version of the app you flew the other map with?

Flew today for the first time with v9.1. Went to an area that I have flown three times previously. Started up fine and selected the old mission that I wanted to fly. Mission started and then the lines changed so that it would have only flown a small area of the field. I did not take off and shut down and closed the app. Restarted the app and tried again with the same results. Finally on the third time I was able to get it to load the old mission and fly it properly. When I went to upload the images the upload button was there but it showed me having 3 flights. Can you look it this and see if the images will stitch properly. Thank you.

The uploader said you had 3 flights or the dashboard had 3 flight entries in it? If it was just the uploader then don’t worry. That should hopefully be fixed in a newer version coming up. It is just displaying the wrong data if you start a plan a few times.