Fix for larger waypoint missions and continue missions

Hey guys,

Pushing a new version to the play beta store that should hopefully fix or reduce the error with waypoints many people are seeing. We don’t want to push this change to all the users we now have mapping so we will just push it to the Play store beta channel first.

The opt in url for the beta channel in the play store is here:

You should also be able to opt out if you like.

It should be online in the next few hours.

1 Like

Very excited to test this tomorrow. Thanks, Chase.

How will we know if we have updated? Will it show a different version?

You get on your Android device you’re using for Drone Deploy, navigate to the link he mentioned and agree to be a beta user. Then you can go to the Play Store and update. If you have not gone to the link first to agree to the beta, you’re not using the version he’s talking about.

When you have updated you can verify you have the correct one by opening the Drone Deploy app, going the the upper left corner to get into the options and noting that you have version 1.1.3.

Did what you mentioned last night but didn’t see anything as far as update. About the time I read your post the update showed up so as soon as wind dies down I will be giving it a try.

Trying to start a 211 acre field now with the new app version. Altitude set at 399 feet, high overlap and manual camera both disabled.

I have green checks on everything except mission. It has been trying to get a green check on mission for maybe 5 min now.

Still not getting a green check after another 5 min. Going to close app and re-try

It’s been 15 min on the second try as well. I believe the estimated flight time was 31 min at 22 mph so less than 2 batteries. I changed the altitude to 390 feet the second try and the altitude warnings went away but it is still churning on the mission icon. By that I mean I have green checks on:

Drone State

I have a blue circle on Mission and the blue circle has a white spinning ring inside of it. Guess I’m giving up for now?

FWIW, this is on a Galaxy Tab S 8.4 with DroneDeploy version 1.1.3. The UAV has .005, the remote has latest DJI non-beta firmware (whatever that is, I can’t remember)

Yeah, that is one of the issues I was worried about. Where are you standing in relation to the drone? The connection needs to be very strong to load the waypoints.

I see a different type of error in your logs. Are you trying to fly a map far away from where your drone is?

I checked the logs some more. This seems to be an issue with distance between two waypoints. I’ve reached out to DJI to ask what that limitation is.

I was 20 feet from drone. Drone was 50 or so feet from the middle of the North boundary of the field to be flown.

I emailed DJI to figure out exactly what causes the error we saw in the logs. It’s not the same one we were seeing before when people were trying larger missions.

Hey guys,

Was able to make a hack/fix in order to increase the distance between waypoints. It’s now releasing to the play store. Should be online in a few hours.

AC: P3 Pro
FW: 1.4.005
DD: 1.1.3
Alt: 390 ft.
High Overlap: Off
Camera Setting: Auto
Area: 110 Acres
Interest: Corn Ortho Map

Flight was the first flight I’ve had since before all the DJI fw issues that went without a hitch. I had about a 5-10 mph cross wind and was pleased at how well it held its flight path. Flight speed and return speeds were much faster since upgrading FW (22mph). RTH between battery changes went as expected. Landings as expected both landings within 5-10 ft. of takeoff location. Continue Mission worked perfectly. Uploading 145 Images. Since this flight went so well I’ll be attempting some larger maps (300+ acre) tomorrow.

I should be trying again in 30 min or less. Excited to see how it goes.

I don’t think ti’s updated in the store yet.

I have 1.1.4.

Now I’m getting an error rather than it just constantly loading. It’s just like it was on 1.1.2

It says “mission check failing!”

Message is:

Error while setting waypoints. Restart app and drone.

It has done it twice now. I did restart the app, controller and drone. I will do it once more with a small mission just to see.

:frowning: it looks like the map you’re trying to make is still a tiny bit too big. Can you try reducing the width a bit and test it out.