DroneDeploy Version 1.2.3 (Firmware 1.05.0011)

Hi Guys,

We have a version that should work with the newest beta SDK firmware 1.05.0011. It should also work with 1.04.0010 and 1.04.006, but it will have the same limitations that existed previously. We recommend upgrading to the newest beta firmware linked below. We’d love to hear some feedback about how it works for you guys before we push this to everyone on the Play store.

I have noticed a bit more difficulty connecting to the drone after plugging in the USB. I’ll be looking at that tomorrow. If you notice that just unplug and plug it in again and restart.

[REMOVED LINKS] Use Play store version.

  • Do we upgrade the controller with the new beta firmware as well, or leave it at 1.03.00?
  • Any restrictions on number of waypoints?

Should be fine with larger maps. You don’t need to update the controller.

@Maakusi I believe 1.05.0011 is camera and Inspire only and not the controller. I updated both my cameras. There doesn’t appear to be a battery update in it, either.

Mission Synopsis on 1.2.3 with FW 1.05.0011:

  • Flew one mission OK.
  • Flew next and initiated RTH mid-mission.
  • App crashed on reloading
  • App crashed once all checks were completed
  • Mission started and immediately initiated RTH
  • Got stuck in that loop for a while. Tried restarting everything, new mission… In the end I reset tablet and that cleared it. Fault seems to be in DD software on tablet.
  • I was able to repeat the RTH error a few times but not consistently - a couple of times a resume or new mission would launch OK but the majority of attempts to resume a mission after RTH would fail with an immediate RTH on take-off.
    At 78’ I couldn’t load an 18 waypoint mission.
    At 200’ I could load up to 32 waypoints, but not consistently. Any more would fail.
  • Got a camera error I couldn’t clear on pre-flight check. Went into DJI App and moved camera and took picture. Could then complete pre-flight in DD.
  • RTH procedure working fine as per DJI app
  • Flight path back to curved corners
  • It was windy - gusting 35kph, so it did wonder a little on corners, but lines were good.

Let me know if there’s anything specific you want further testing on.

Starting a new mission without restarting the app has been an issue for a while. I’ll make sure it is put on the list for this or next week.

I always quit the app and restart between every mission. The above issues were with doing that.

Thanks for this feedback. I’m going to do some testing with the waypoints that failed to load for you and see if there is something we can do to fix it.

Figured out both issues. Looks like the home button got pushed which caused the RTL. I’ll make the home button disabled until the drone gets to a reasonable altitude. The other issue was something to do with a new DJI restriction which is an easy fix. Should be fixed in teh play store version.

OK, here goes … the good and the bad. No ugly today.

The Good
DroneDeploy & DJI are working together again. First mission went off without a hitch. Firmware updated to 1.05.0011 and DD app is 1.2.3. Using Samsng Galaxy Tab A SM-T350 with Android version 5.0.2.

Literally without a hitch – app opens reasonably fast (still slow on connecting to DD screen and on the Calculating Initial Plan screens, but no real hickups). I prepare a mission with about 20 waypoints, 200’ AGL. Checklist all green, takeoff smooth (no hover at 1.5 metres though – it just went straight to 200’ and lifted landing gear on its way up. Flew the mission as expected – lines dead-on as before, and turns were smooth without any sticking at the ends.

The Bad
Still having some issues with continuing mission. My routine was as follows:

  • RTH with the button in the app Power down drone,
  • switch battery
  • Force close the app,
  • reopen app
  • Wait for the “Older” button to appear (probably only 30 seconds, but it seemed to take a long time to
  • Selected the previous incomplete mission, checkmark
  • Select “Continue” rather than “Start Over”
  • No checklist appeared. I waited at least 5 min or so – no pre-flight checklist came up.
  • This flight is labelled “Did Not Continue” in my dashboard

Other issues:

  1. Repeatedly had the app getting stuck at either connecting to drone, or Calculating Initial Plan stage; never was able to complete that mission, and had difficulty starting new ones as well. Found the most reliable way to reboot was to force close app, unplug USB, and then select DroneDeploy app when prompted with fresh USB connection.
  2. Tried continue mission on an older mission from several days ago, got the following error message: “Mission Check Failing. Error while setting waypoints. DJI’s public firmware can sometimes fail writing waypoints. Download the latest beta firmware (1.05.011) linked on our forum to write waypoints more successfully.”
  3. Created another mission at lower altitude, with many waypoints (I would estimate 40 or 50 waypoints). The app just crashed completely when I called for the checklist.
  4. Finally, wrote another smaller mission at 100’ AGL (it was getting dark). Flew half the mission, did RTH with the Home button on the DJI controller; switched battery on the drone, restarted app and used the usual routine to Continue mission. This is a weird one … it restarted that mission again, flew the mission to where I sent RTH the first time, and then started heading home again. Only it didn’t stop at the home point, but just kept going along that same line. I eventually switched to P flight mode and brought it home manually.

And one more last issue. After the last flight, I thought I would send it up with DJI GO just to see if the new firmware would work with that. Flight behaviour seemed OK, but the GO app was taking pictures automatically at regular intervals. Confirmed that those images are actually on the SD card. It just kept taking pictures several seconds apart for the entire flight. Not sure if that is still in some kind of buffer from having your mission written to it?

Look forward to testing again soon.

we’ve got two people now finishing up the offline functionality which should also help with the issues you were seeing with the checklist and continue mission. Thanks for the other feedback!

I’ll second that - Now if only there was an easy way to exit and restart the app… (am I missing something there??)

We’ve also made it a habit to reboot the mobile device to “clean out the cobwebs” before a mission or series of missions.

1 Like

Just downloaded (Firmware 1.05.0011) and loaded to my I1, updated app to latest Version – all seems to have gone smoothly, app opened, connected, map showed and waypoints popped up with adjustments flawless. Only thing- dark and raining here so will test out tomorrow. Cheers guys.

the public firmware 1.4.10 is compatible ?

1 Like

Public firmware should work but you will probably run into issues setting waypoints more often. You also won’t know if there is an issue until a bit after takeoff.

Hey @chasemgray Here is some feedback on the 1.2.3 with FW 1.05.0011 on an Inspire 1 as we did 5 successful flights with the app with a Galaxy S4 with a few issues to consider:

  • In 3 different times the UAV took off, hovered for 5 seconds and landed. We reset everything and it worked;
  • On 2 flights the app lost contact with the UAV (“not received any message for 10 seconds” error) but we let the drone finish the mission and it landed safely, but we couldn’t see the progress on the DD app (we followed on the DJI app);
  • The app crashed 6 times during the check list stage for different flights and after each time we reset everything (including the phone) until it worked;
  • We got the “mission check point error” also 6 or 7 times for different flights and again we reset everything until it worked;
  • We also got a few Camera check errors but after resetting it worked

We also did 2 flights with an Galaxy Tab 4 on 1.2.3 and the same UAV

  • The app crashed A LOT with the Tab, at least 10 times for each flight and after so many resets it finally worked but we lost almost an hour for each flight;
  • Again in one of the flights we lost contact with the app but the mission went as planned;

Conclusion: The app works fine, other than losing a lot of times (and battery) on the reboot process we manage to get all of our flights, the only problem we had after the flights is that for some flights we can’t access the flight log on the computer (it shows no flight path and/or shows 0 images taken)

Hope that helps! Feel free to ask me anything you need!

What base DJI firmware can we use before putting the drone deploy firmware on. my inspire is on 1.2.X, i wanted to update to dji firmware, and then load drone deploy on top of that. is that how this should be done?

It is a DJI development firmware. Not a Dronedeploy firmware. You can load it with any base firmware and it should be fine.

Hey guys I have had all the same issues with booting and rebooting, trying different sequences of powering up all with mixed results. when it works it works great, it just seems to take several tries for every mission to get it going.
I am excited to see how close it is, but it is frustrating when trying to demonstrate or use consistently.
just starting today my issue is that the camera will not work, keep getting error, no error on Dji Go app, but will not allow it to start mission. I thought by updating to latest version that would 1.05.0011 fix it, I was wrong. still getting the same error as before.
I have a job with this tomorrow and would love to get a little guidance.
I can always just manually shoot it but is so cool when it works right and is so much more consistent


It’s difficult to say exactly what is causing the camera issue. What it does is put the camera into capture mode and take a picture. If somehow any of those steps fail it tries again up to 3 times. We assume if we can’t do that then starting the camera in the air will also fail.
I’ve only had issues with the camera when my signal wasnt good. I’ve also seen issues when the camera actually is in a weird state such as playback mode and the SDK had trouble switching back to capture mode.
I’ve never seen an issue where the camera check always fails. There should be a retry checklist button when it fails. Have you tried this a few times?

Regarding connecting. Dji now requires the android device to detect a usb connection from the RC before we can do anything. I usually try turning off the RC, starting the app, then starting the RC. The android device should prompt if you want to use it with Dronedeploy or DJI go. Select dronedeploy and then it should usually connect after a few seconds. You did say you’ve had camera issues. The app uses the connection to the camera in order to detect that the drone is connected and online. If there is a weird camera issue I could imagine it affect consistently connecting to the drone.