Unable to fly mission - Waypoint upload and Camera check hang

I tried unsuccessfully to fly my first Drone Deploy mission yesterday after flying with the DJI Go app then doing a ‘force stop’ with Go before running Deploy.

  • P3S with latest firmware
  • Latest Android version of Drone Deploy
  • I got a ‘Drone connected’ message (wifi connection as its a P3S).

The pre-flight check ran, but the ‘Checking waypoint uploaded’ and ‘Checking camera’ just showed the spinning circle. Everything else, including ‘Settings’ below the camera check was OK. No error messages were generated.

I obviously didn’t try to fly the mission - I don’t suppose the app would have let me anyway.
I flew with Litchi instead, FPV and pano modes and that was OK.

So, have I missed something I wonder?

Suggestions on the FB page were to shut down DJI Go - this I always do when swapping app, and also do a ‘force stop’ and that there needed to be at least one photo on the SD card - there were jpg, raw and mov files on the 64Gb card and loads of space remaining.

1 Like

OK, tried again today with two different android devices. Same problem with the first one which is WiFi only. Tried my Android phone too in case an internet connection is needed. Did a ‘Clear data’ in the app and now I can’t connect the drone at all. Hmmmm.

The app is prompting me to connect my USB cable, which obviously doesn’t apply to the Phantom 3 Standard that uses a wifi connection.

Now I’m confused!

A bit more testing but no further forward. DroneDeploy uninstalled and reinstalled on my Samsung Tab A and now I’m getting a ‘Drone Connected’ message - good!

However, when going through the pre-flight checks, DroneDeploy still doesn’t get past the ‘Checking waypoint uploaded’ and ‘Checking camera’ and just shows the spinning circle.

Also, the position of the P-GPS/Ati/F-GPS switch is not recognised. No matter what position the switch is in, I get a green tick in the pre-flight check. Still no error messages, just the pulsing circle next to waypoint upload and checking camera.

I suspect that DroneDeploy, although connected(?) isn’t communicating properly with the P3S.

Also, if I try to run the sim, I get a warning message that the ‘mission exceeds maximum radius set in DJI app’ but I have this set at 300m (about 1000ft) and the mission is a very small 5 acre 4:23 min task that’s well inside the 300m.

Hey I’m having the same issues with the app right now as I’m writing this. For the last thing that you mentioned with Mission exceeding maximum radius turn off beginner mode and maximum distance limiter and have your max altitude at 120 meters which is 400 feet regulated height. You probably already knew that.

As for your other issue with the checking camera and checking the waypoint I’m having the same issue and I cannot figure it out if you find anything let me know I’m trying everything. I uninstalled dronedeploy and dji go and reinstall them both and still nothing is working. I formatted the camera even on dji go, still nothing.

Well it appears that we’ve all tried the same troubleshooting. I first used DroneDeploy successfully on 7/10. I was out of town for the following week and tried it again yesterday and it is getting stuck in checking Waypoints and Verifying SD Card same today. Yesterday I was also occasionally getting the warning about exceeding maximum radius even though DJI Go is fine. The one difference between 7/10 and now is a new DJI Firmware. I’m wondering if something in the DJI firmware has messed with DroneDeploy.

Seems like a lot of people have been getting this issue in the last few days, but no responses.

Well by now drone deploy has got to be aware…

I haven’t had any new dji firmware uploaded to the drone it just updated recently on my Android phone but that’s…probably what did it damn it!

We’ll check to see if there is a new firmware that could be causing android issues.

FYI: I’m including these two screen captures from my Android because I’m also getting the message about Setting Change Require on Android 6 about clearing the DJI Go Application Defaults. Although as you can see from my other screen capture, they already are cleared.

We aren’t able to determine if they are cleared. We show that on each launch because of how big of an issue it has been for our users. Most will use DJI go and then dronedeploy and not know why it doesn’t work.

At least it’s good to know that I’m not the only one with problems.

I go through the process of a ‘Force stop’ every time I swap between DJI Go, Litchi and Drone Deploy and sometimes I have to do a Phantom off/on or even a device off/on to get the live camera video to appear in Go and Litchi. I’ve tried to figure out a routine that works every time between Go and Litchi, but it seems a bit random so there’s obviously something going on in the background.

With regard to DroneDeploy, beginner mode is off, maximum height is set above the height I have set for the DroneDeploy mission and I’ve also tried turning off the distance limiter but still no joy.

I think that I’ll wait for further info as I think that I’ve tried everything that’s going to make a difference.

1 Like

The failure of the sim to run has been solved by Mario:

I am planning my flights in Switzerland. If I run the sim after planning i always run into this error. I’ve realized that when you run the sim it always takes the GPS location from this park at nice San Francisco , hence my plans are a some odd thousand miles away from this GPS and then it fails

If I move my flight plan to this nice park in San Francisco where the GPS flag is located I do get the Simulation to work…

I started the sim and ran a simulated mission based on the sim GPS flag in the San Francisco park and it worked fine.

Just need to be able to fly a real-life mission now!

Has there been any solution to this issue? I am in my second week of the dronedeploy trial period and I cannot use drone deploy! The past 2 days I have not been able to fly my missions to check on some fields!

We tested out the new firmwares. I’ll send you an email to see if I can get some more information to try to get this to work for you and figure out the issue.

1 Like

Not working for me either and I’m the original poster. I also signed up for the Android beta test but nothing heard back.

I’m happy to provide you with any information you need to help to resolve this problem so that I can fly. Please get in touch.

After the latest DroneDeploy upgrade they broke it for at least the P3S. If you try and follow the clear instructions you will see those are for a P3A or higher with lightbridge, since a P3S dont connect via a USB cable.

On 7/15/16 i was able to fly a mission and then later that day DroneDeploy published a new version and this version broke the P3S. I get the same issues as stated above. Click Fly and get 12 gps but it hangs on uploading the wavepoints. So whatever new api’s they are using looks to be more for the P3A and above.

Many thanks, yes I did notice that it only mentioned USB connection between the controller and the device, but I hoped that was just an oversight in the instructions.

Here’s hoping that DD can be made to work with the P3S again. The recent price drop for the P3S following the introduction of the P4 will mean that the ‘S’ will continue to sell well and might be the first semi-professional drone that some will buy - as it was for me. I’d love the P4, but at over twice the price of the P3S, it’s just too much for hobby use for me.

Anything? It could have been the app update too. I’d be happy to provide data. But give me a heads up if you are going to email first.

I just tried flying again, still the same issue of being stuck on verifying camera sd card and waypoints. Except now drone deploy won’t launch its app with my drone connected to my android phone after closing DJI Go! I get a simple error saying "file///android_asset/www/index.html "

After Googling this I found out that this is an app timeout error. So I tried the back door, meaning I closed everything on the phone and shut the drone off, and then relaunched the Drone deploy app, it opens up fine, I turn the drone on and have it connected and set to the right GPS function and the drone deploy app recognizes my drone. Go to the flight that I have been trying to fly the past 3 days now!!! and…

Stuck on verifying camera sd card and loading waypoints!!! What the heck is the issue?? Is drone deploy not compatible with Phantom 3 standard all of a sudden?! Why won’t my app even launch correctly with my drone connected and DJI Go is closed and stopped?! This wasn’t even an issue yesterday when I tried opening the App with the drone connected. Now the app won’t even launch if the drone is connected before launching DroneDeploy.

I have to start DroneDeploy first, which is out of order already, then turn on my drone and connect it with the WiFi, and then the App will recognize the drone is connected. Yet still, when trying to fly and doing the pre-flight checklist…Stuck on verifying camera sd card and loading the waypoints!!! This is really annoying and I hope this gets fixed I love how simple and easy to use drone deploy has been so far. I’ve done four flights with it already during this trial period, and this week it hasn’t worked at all for me. Please help!!

Hi, Obviosly the problem is with the app. I flied a mission on last 14/Jul with no problems. Yesterday (20/Jul) I tried to fly again with exactly the same equipment but never update the waypoints and the SD space… The only problem was that the app was updated automaticaly… that’s the problem with the automatic update…

We claim for DD to permit to downgrade to prior version to continue flying.