V.1.0.4 unable to Connect to Inspire 1

After updating the firmware on both the Inspire 1, and downloading the v.1.0.4 apk, the Drone Deploy app does not want to connect to the drone. I have assured that the DJI Pilot app is NOT running in the background when attempting to connect with the dronedeploy app. I did however perform a system check with the DJI Pilot app and everything seems to be in order. To summarize, the DroneDeploy app is always stuck on “Waiting for drone”

Usually we can connect even with the wrong firmware. The firmware usually causes problems in later steps.

Are you using something similar to Jmann as your username? I don’t see any user that has registered or loaded the app with that name. Did you sign up for a dronedeploy account using the app and login? If you are sure that you can connect with the Pilot app then I would think that maybe you aren’t logged in.

Ah, I didn’t realize I had to sign up IN the app itself. After creating "thejmann07@gmail.com" account within the app, it works just fine. Thank you very much.

I have a similar problem, but I do manage to connect to the Phantom 3 but the software asks me to change flight MODE. Although Ive done this several times, checked also that multiple mode setup is activated from DJI PILOT app (closed that) and IOC as well, its still not working. Checklist is ok apart from this.

Do you have the beta firmware listed on our getting started guide, not the firmware on DJI’s website.

I did install this beta firmware version as advised to Phantom 3 and RC.

And switching to ‘F’ mode before flight doesn’t get rid of the error? What username are you flying on? If you don’t want to post it you can email beta@dronedeploy.com and we will look at your logs to figure it out.

I’m having the same problem with the p3p. It’s driving me nuts!

What is the username you’re flying under?

We’ve solved this issue now many times. It is usually the wrong firmware but I’d like to check our logs to see.

Username is markaguille


I never see that username pop up in our logs. Can you explain the exact steps you are doing to connect the P3?

My user name is markaguille@gmail.com. Turns out

I still am not able to find any record in our inspire logs. I do see you have a dronedeploy account but we have no record of an app load, attempted connect, etc.

Can you launch the mobile app and log in? I’ll keep an eye out to see if we can see anything.

Are you using the Android app that has 1.0.4 at the bottom of the left sidebar?

sorry Chase i’m on the p3 pro

The p3 pro should work the same. I would see those in our logs as well.

I logged in and back out, then back in again. If you can’t see me at that end, maybe that is the issue?
Where is this dashboard? I can’t find it.

Found it now!

Can get on some sort of chat? We have a chat on the main dashboard of dronedeploy in the bottom left corner. I’ll be on that when you send a message so we can move quicker.