New FW released

we got the new oficial FW released. it says SDK supported, hopefully it will allow us to fly with drone deploy.

if not i just tested it. we can downgrade to and them install the FW recommended by drone deploy.

lacion, Let us know how your tests turn out.
I just borrowed an Android tablet yesterday to test out DD, but I couldn’t get the DD app to connect. I then went back to read the FAQ and setup guides and it said the DD app works best with the inspire beta firmware. I didn’t want to put the beta FW on my inspire, but now that the new FW is officially out, I want to try it out. Just can’t bring myself to be the first guinea pig! Thanks

No pain no gain my friend.

True, I’m in the process of updating firmware and app now. I couldn’t wait haha.

Hi Guys,

Everything worked well with our Phantom 3 update to firmware version 1.3.20 and the app ran a mission fine. Checking Inspire 1 firmware now.

I haven’t managed to get it to work either with 1.0.5 or 1.0.8 of the .apk.
Check list stops and fails at firmware.
Is there anything in particular you’re doing in the sequence that might be different?

I normally start the DJI app (go), make sure everything is OK, then close it and start DD.
Everything seems normal until I try to take off. Wifi, controller and GPS pass but looks like its thinking about drone state then shows the wrong firmware error.



Are you talking about Inspire or P3? I am still testing out Inspire.

It looks like the currently released Inspire firmware doesn’t return to one of our firmware checks. I’m not sure the inspire firmware released has full SDK support. Does it work for anyone else running autopilot, etc.? This is pretty weird because the last inspire public firmware release worked most of the time with the SDK.

The Phantom 3 firmware is good though.

P3. I assumed that there would be more solid SDK support in this one but sill get stuck.

How does the DD app verify the firmware version? Is it a call through the SDK and would it be something as simple as the FW returning a version number that isn’t in the list of approved FWs in DD?

I’m surprised you’re seeing a firmware error on the P3. Most of the time we can’t determine the firmware. DJI doesn’t tell us. We just check for methods we need in order to operate.

Anything I can send you to show the error?

We have most of the info in our logs. I’m checking now.

It looks like the groundstation is not returning, which is what is happening on the latest Inspire version. Which firmware version did you install?

Can you try to downgrade to the 1.2 version and then upgrade again? I’m not sure if it’s possible.

We have seen issues with upgrades not working even though they say they were successful. Re-updating worked.

I installed the latest FW on offer from DJI - tried to downgrade but apparently you can’t after this version. All upgrades (and supposedly downgrades) go through the remote. when I put the Beta FW on a SD card and fired it up it made a hell of a racket - so I assume that’s a no.