New Public DJI Firmware out today w/ Waypoints

Looks like DJI finally released the new firmware with waypoints today ( for the Inspire). Is this version capable of being used with DroneDeploy?

it looks like the FW is the same as in the beta, and it looks there is an issue for this FW that requires the aircraft to be in the air before the ground station features can be used.

My Inspire 1 SDK firmware, which was the last version recommended for DroneDeploy

Just tried it out with today’s released DJI Pilot app. Did not change I1 firmware. Worked really well, as soon as I flipped to F mode, it brought up the the waypoints, etc. options. I had the Inspire already in the air. So, looks like for the time being I can leave the aircraft firmware alone and still have all functionality for both the DJI and DD apps

I’ve tried using DD with the latest FW and I cannot get past the pre-flight remote state check.

It’s not going to work. We knew they might be doing this and had a plan for this and will have something out ASAP.

Curses! I just upgraded to the latest DJI fimrware - P3X_FW_V01.04.0010.bin on Sept 7th and now I can’t install the DroneDeploy firmware - P3X_FW_V01.04.0005.bin. Really wanted to experiment today. I guess I’ll have to wait until next weekend or whenever DD’s fix is out. Oh well, at least the DJI firmware’s POI and Waypoints work!
I guess I should have tried my experiments in reverse order, eh?
As Andy mentioned above, my pre-flight check list does not get past the firmware check (I think).
Looking forward to the next update.

It won’t let you downgrade the aircraft?

i’ve been beta testing this firmware and everything worked fine

You were able to get past the state check of the F mode switch?

I’m running everything now to fix/test if possible. Having a fun Labor Day :smile:


Alcohol is required for dealing with this.


Hey guys, I’ve got a version working, but we’ve had to change a bit of how we load waypoints. Given the trouble we’ve had in the past I’m going to keep testing and hopefully release a version tomorrow afternoon.

Upgraded to the new DJI Go app yesterday with P3X_FW_V01.04.0005.bin on the P3P and the new features work for me

Been looking at the dd app for a while now. I take it Inspire 1 Firmware v1.4.0.10 will not work???. I have upgaded air craft and rc! Will dd only work with beta???

Hi Guys, Ive been away for some time from testing DD but had such issues that Ground Station checking didnt pass and left it at that point with Pha3Pro. Do you recommend that I should wait until new DD firmware comes out or just go for it and test it with the present one?

i think alcohol is required in general while dealing with DJI

1 Like

Nope, can’t downgrade. After I tried, the .txt file says it can’t go back. Usually it says “Success”.

Should have a version out to work with the new firmware a bit later today.

have you guys seem the new camera?

that looks amazing for photogrammetry. specially the raw one. not to mention that for mapping being able to change lenses is really really cool too, almost no distortion just 0.4%

1 Like

Saw it yesterday when DJI officially announced it. I want one!