Problems with DJI firmware update to and DD

I ungraded to DJI Inspire 1. DroneDeploy returns “Drone State Check Failing”. Firmware check failed. So I/m grounded at the moment.


yes everyone with the latest BetaFW or the released one is grounded ATM

We spoke with DJI and it sounds like ground station support isn’t in the released firmware. They said it wasn’t in the inspire or the phantom firmware. I tested the phantom firmware and it worked so in a bit confused.
We will hopefully have some more details soon.

1 Like

seems like we should thank the all mighty for the maps we have done so far them eh?

their making testing and using their multi rotors very hard.

It’s not just testing. Our customers don’t want to hear we can’t do photography for them because we’re unable to fly. They are happy to call someone that can provide them with photos that aren’t having DJI related problems. I’ve about had it with DJI! Bad customer service, they still haven’t provided features that they promised and then they put out version and in their “How to Update Firmware” notes it says that DJIGo app is needed for the upgrade but it’s not available yet for Android. DJI is expecting 3rd party vendors to deliver features they originally promised and putting out firmware that causes 3rd party software to be nonfunctional. Now I hear that Inspire 2nd controllers won’t work. I’m afraid to fly at the moment not knowing if I can trust the company or the software they provide.

Does anybody at DJI know what they’re doing?

They’re making it extremely difficult for us to run a business.

O.K I’m done. Rant over.

I learned that lesson the hard way. With DJI, I take the “if it isn’t broken don’t fix it” method. I will upgrade my firmware when I know that it had been tried and tested by the masses.

I am still on the previous officially release firmware with my Inspire v1.2.1.06. I could never get the DD app to connect to my aircraft and It sounds like it wont work with v1.3 either.

So am I correct thinking the only firmware version that works with the Inspire and DD is the beta version which is linked on one of their tutorial pages here? I thought you had to apply with DJI to use this beta version of their inspire firmware.

This is the sdk firmware. You can easily sign up and download it yourself on their developer website.

There is a newer release as well that we will be linking tk soon. I think.

im still using 01.02.0004… should I upgrade when you update the tutorial page?

So has anyone had a successful flight with the latest firmware from DJI for the Inspire?

We’ve been told by our contacts in DJI that it doesn’t have groundstation SDK support. We also tested it and tried several combinations to get it to work with no luck.

Thanks for the update. Will uploading a previous firmware fix the problem?

It sounds like you can go from a 1.3 version to a 1.2 version based on what our users have said. @jono will be doing some tests today or tomorrow.

I’ll be interested in what you learn because we have tried to return our Inspire 1 aircraft and controllers to v1.2.1.06. The aircraft appears to be downgraded but we can not get our controllers to downgrade. We have tried to downgrade using a USB stick, then we tried to downgrade by putting the software in a micro SD card in the camera and attaching the camera to the controller. We tried two different brands of micro SD cards. We can not get the controllers to downgrade.

We’ll keep trying because we need to get the aircraft operating as we have weekly jobs to shoot for our customers. This software from DJI is causing us a real headache as I’m sure it is for you too.

the only thing that can be downgraded is the aircraft, nothing else.

Thanks for confirming what we have found. Controllers can’t be downgraded. Thanks to DJI, we are out of the mapping business until this can get resolved. Should I send DJI invoices for our lost revenues?

You can downgrade the controller. Will post directions once I get into the office. It’s not straightforward.

It is beta software after all!

Here’s a link to the tool which allows you to downgrade the RC. Treat it as a normal firmware files (load onto a USB stick, plug in, and power up the RC). This will clear all firmware on the RC - so you will have to reinstall some firmware to use it again afterwards.

Please don’t share this outside of our beta :slight_smile:

1 Like

Thanks. Im still having trouble downgrading the copter. I currently have the latest firmware on the copter. How do I go about downgrading?