Beta V9.1 Release (DroneDeploy 1.0.8)

Version 9.1 (1.0.8) is now out!

Download the APK and Check out the Release Notes. For those first getting started, please read the Getting Started Guide.

We’re excited to get your feedback! If you have any feedback or bug reports specific to this version, please reply to the V9 topic in the Bugs and Feedback category.

Most Notable Updates:

  • Fixed a bug with converting between feet and meters on the altitude profile setting.
  • Improved shutter speed settings
  • Ability to set any altitude between 20m and 120m.
  • Removed downloads completely
  • Upload speeds improved on desktop
  • Warning when connecting Phantom 2 to the Inspire/P3 app
  • New mission temporarily removed
  • Bug fixes based on customer feedback.


can’t get the file to download right again. Tried unzipping the file to read Release Notes and just got a file that i can’t open. lost the the .bin file. I’m running a iMac.

Hi Steven,

Which file are you unzipping? You can access the firmware from our getting started guide in the tutorials section and the .APK file in this thread is the application to install on the Android device.

Public firmware 1.3 is being rolled out today (p3 already I presume Inspire later today) being supported by the renamed Pilot app, DJI GO.

Do we stay with the DD available firmware or update to this public new one?

In order to use the functionality of the new DJI app 1.3 is needed, so DJI say.

Doesn’t look like the DD app supports the 1.3 FW on the P3 Pro at this stage.
Passes GPS, Controller and DJI Wifi checks but falls over on drone state for me.
Also gets very upset if you try to load an older FW (squeals and makes a hell of a fuss).

Hi David, Please give us a day or two to run some initial tests. Our first engineer will be in the office in the next 6 hours, and will start testing from there.

Agree. New FW for I1 is not passing Drone State test after upgrade. Will wait for the tests before any more mapping.

That usually means there is no SDK support or an error while opening the ground station. Am testing now.

Awesome…thanks! Will check back with you in a couple hours! -Chris

Any news on releasing DD update that works with DJI 1.3.2 firmware?

We can’t release an update. DJI has released a firmware that is going backwards in sdk compatibility. They don’t have very well organized releases and they don’t test things well.
That being said I think they are aware of the issue. It’s unclear how long before a fix comes out.
I’d recommend using the 1.2 firmware.

New to DD - Thanks for the app. I just signed up and logged into the forum, download the latest v9.1(1.0.8) and installed it on my device.
When I open the app it ask me to login with my email address. I tried both, my email address and user-name and it does not like my password? I even requested to reset my password (on the web, signed off and back on again) and tried to login again on the app with the new password and both email address and user-name – no luck.
Then when I press the back button, it seems to take me into the app, because it tries to connect to my drone.

  • I cannot logon to “Cloud Control for Drones” - is this a known issue?

Yeah i got confused with that at first too. Signing up for the beta is diffrent from signing up for your cloud account. Just create a new login from the app.

I have a P3P with firmware SDK P3X_FW_V01.01.1007
I have not installed the new firmware (V01.04.00.01) your beta is compatible with the firmware P3X_FW_V01.01.1007 ?
In your guide you say you set the remote control in A Mode but DJI SDK says to set the remote control in F mode and no longer in A mode, which is the correct way.
Thank you

F is the correct mode, and ideally for P3P, we prefer v1.2.4 (until 1.4 support is confirmed). You can find the link and process to update this in our documentation here:

1 Like