Recent Issues

Had a rather large job recently and had quite a few errors / crashes with DroneDeploy.

Not being able to take off. All checks passed, clear to take off. Click the tick button and nothing. Happened multiple times - possibly battery temperature under 15° . Does DD check batt temp and if so can we get a warning if it does detect it is under 15?

Option to resume mission not appearing on dashboard. Flying a large area, 4 batteries or so. Not every time but frequently the option to continue did not appear. Sometimes it would act as if the mission was complete and button would say upload. Other times it would act as if the mission had not been flown and the button would say Fly. Pushing the fly button would cause the drone to continue where it left off, but often the app would not track the drone while it continued it’s mission… no flight data available either.

Camera not tilting down. One of the missions the camera did not tilt down at the 1st waypoint. It continued to face straight and take photos. Easily fixed as I could manually tilt it down so no biggie but just thought it was worth a report.

App hang during check list. Happened multiple times. Either Uploading Waypoints would remained grey or the bottom check on the list would… (settings?).

Inspire 1, latest firmware. Ipad Air2.

Hi @Captain_Salty, can you please try on the new version (2.0.12) of the iOS App?


I am on the latest version. Had another job today that I could not complete because of DroneDeploy bugging out.

First issue was the Connect A Drone message. Tried both IOS and Android apps, both giving the same error. DJI GO app working fine. Restarted everything over and over and eventually got it to work about 30mins after setting up.

Second issue was the craft not following the grid lines. See below:

Third issue was the craft disconnecting in flight, error message “Bad Connection etc” No environmental reason for this to be happening - craft right in front of me with clear LOS. Unplugging and re plugging the USB from controller to ipad occasionally got connection back.

Fourth issue and most concerning, was when continuing one of the missions, the craft flew to the start point - then slowly began to fly away and descend. You can see below the path it took. The route also did not load correctly, showing the uncompleted portion of the mission as completed and just making up it’s own mission (from start point to end point - this was not part of my mission).

Fifth issue… I thought at least I got some areas mapped to deliver and discover that half the images taken are totally over exposed and the entire day has been a complete waste of time. Camera set on auto.

Hi,sorry to hear these weren’t useful flights.

The connection issues are hard to improve. DJI is working on a way to improve it on android very soon.

The photo that shows it not flying the flight line is actually just skipping a section of the line on the screen due to a disconnection. It actually flew that section but we couldn’t draw it due to being disconnected.

We have very little control over the disconnections and Reconnections. We will keep working with DJI on ways to make this better.

The exposure issue is something we are working on. It can happen rarely and it is a high priority issue we are fixing.

Thanks for the quick reply. Good to know that it was actually flown and just not drawn on the map. These were all flown via IOS in the end.

Is the disconnect an issue between the ipad and controller?

Any ideas about the “flyaway” (2nd image)? That was a little scary, glad we were high.

The disconnect is most likely happening between the ipad and controller, yes.

I’m not exactly sure what could have happened in that second image. Especially since all the other missions were fine.

Great, thanks. I will switch out controller and cable to see if it is a hardware issue.

Yeah all I can tell you is what I saw, the continued mission should have started mid way through the grid that appears already flown in the image (it wasn’t) and after taking off, new start and finish waypoints appeared.

The inspire then flew to it’s new start point and appeared to begin to follow the line, I noticed it appeared to be descending slowly. It then turned 90° and started to fly off the line and descend. Thankfully flicking back into P mode regained control and I was able to bring it home safely.

Please don’t take this as me having a go at the app, I appreciate the fact that it is free and constantly being developed - I just thought it would be beneficial to report this weirdness!