Problems with remote mission

Hello everyone. I’ve been experiencing some problems around flying remote missions in locations without cellular or wireless network reception and I’m wondering how people have gotten around that.

Having created the mission the day prior, I loaded drone deploy and the mission up to the point of needing the pre-flight check. I get out to the site and upon turning on the Mavic pro 2 and getting it connected to the remote and DJI go 4, Drone Deploy suddenly doesn’t show that specific mission in my list of projects and needs to connect to the server.

I leave the site to find reception. I perform the same steps above and get DroneDeploy past the pre-flight check. With the drone, remote, DJI go 4 all turned on, and drone deploy at the green button to start the mission, I enter the site and get ready to fly. I anticipated there being an issue because the pre-flight check happened offsite, and the mission couldn’t start. Turning off and on the drone and DJI go 4 fixed that, and I was able to then perform a new pre-flight check on DroneDeploy and start the mission.

Everything ran smoothly until the end of the drones third battery. Before the drone returned to home for a battery exchange, I switched from drone deploy to DJI go 4 to check a setting. I return to drone deploy only to have the app restart, and just like earlier that day, the current project was not showing and DroneDeploy needed to connect to the server. Hence I couldn’t resume the mission once the drone returned.

What steps do I need to perform prior to leaving reception to make sure I can fly a DroneDeploy mission in a remote area? Burning drone and remote battery while traveling to the site after DroneDeploy’s pre-flight check on a project is not ideal. And then how do I prevent the app from restarting mid-mission and needing to connect to the server when I’m already in a remote location?

Any help would be greatly appreciated. Using iPhone XR

1 Like

I want to add some more of my experience. Upon writing this post I was unaware of “offline mode”. After writing this post I made sure 4 missions were in offline mode. I watched them all get to 100% in terms of having the base maps available.

Hours later I returned to an area adjacent to the remote area mentioned above to fly these 4 missions. I loaded up Drone Deploy before leaving signal reception. When I looked for the missions they were not available. DroneDeploy was trying to connect to a server, just like the prior day.

Offline mode seems to have made no difference.

1 Like

From my experience i have had the same problem even in areas with cellular reception. The culprit…DJI GO4 running at the same time. When I shut that down and restarted DD everything worked as it should have! Not saying that will work for you, but it did for me.

1 Like

Some catch-up with my experiences:

  • Drone Deploy exits the iOS app mid-first battery into flight. Restarting the app does not show any of my offline projects and when the drone comes home to have its battery replaced, I can’t continue the mission. DroneDeploy says it cannot connect to a server.

  • I successfully fly a mission and after DroneDeploy asks me whether to upload the images now or later, I choose later, return to the projects page to fly an offline mission just a few hundred feet away only to see that once again I have no offline projects available and DroneDeploy cannot connect to a server. This time the app was never exited, purposely or on its own.

  • I fly 90% of a long multi-battery offline mission. Weather stops me from making last flight. I captured livemap images for the duration of the flight. I return the next day to complete the mission. DroneDeploy tells me the mission is incomplete and would I like to continue the flight? I click to continue the flight. The pre-flight check is successful and the drone takes off to continue the flight from about 25% into the flight. I have no idea what happened here but I can’t wrap my head around there being livemap images showing on the map which means the drone completed far more than 25% of it’s mission, but DroneDeploy ignores over an hour of already flown flight.

  • iOS app very slow/unresponsive. Restarting it changes nothing. Restarting the phone changes nothing. This combined with not being able to rely on the app when I am in an area of no reception without a guarantee that the app will allow me access to offline missions or not exit mid-flight is exceedingly discouraging and frustrating.

I’ve tried not running DJI GO4 at the same time, leaving the phone in airplane mode once the app has been loaded in an area of no reception, and these issues persist.

1 Like