Plan upload failed: There is not a mission available

Mavic Pro
ipad 7, ios 15.1
DD 4.66.0 (ios version)

Today I created some missions online. Went to the field at lunch. Turned on the hotspot on my android phone, then connected to it with my ipad 7. Confirmed internet connectivity on the ipad, then powered up my mavic pro, powered up the controller, and plugged the usb cable into the ipad.

Drone connected up immediately (yay!), and the checklist was successful.

I manually flew up to 120’ (plan starts at 130’, and I’ve never been able to start a mission from the ground by tapping “start flight”), added 3 pano flights to the queue, then tapped “start flight”. DD thought about it for a bit, then failed with the message “Plan upload failed: There is not a mission available”.


It then went thru the 3 pano flights…it tried the flight, failed with the same error, went to the next, etc, till it exhausted the queued flights.

Then it decided to land the mavic pro. And in a 200’ max LAANC zone, the drone began to climb and yaw towards “home”. It climbed to well above 200’, without flying toward home. I manually stopped it with the mode switch on the controller, but it looked like it was going to climb forever. And

I tried multiple times to re-select a mission and “start flight”, but the behavior was the same every time.

What the heck?

1 Like

I guess I should clarify that I’m not just ranting here…I really need help with this! I need to know why this happened and how I can make it never ever ever happen again. So any of you smart people who have figured this out and fixed it, please comment!


Hmmm… I keep thinking about this, and one thing that I just remembered is that this flight is in a 200 ft LAANC area. While I was on my computer before I went out to fly, I requested and got LAANC approval through drone deploy. Do I mayne have to first start the dji app and check the warnibg box that pops up, and then close it and start drone deploy? Is that possibly why the flights failed because I didn’t do that?

Ok, it’s possible that “authorization” is the issue here. I’ll go thru these steps today at lunch and see if that allows me to fly here.

Did you unlock the controller through DJI’s self-unlock site? Normally it is pretty easy to go through the windows and 5-6 checkboxes unless you are in a zero cell. If it is a no-fly then there is a completely different set of prompts in DJI that are not easy to get through. That said I have never seen anything in DroneDeploy related to airspace. It just won’t proceed.

I haven’t done any unlocking. This was the first time I’ve flown this specific site with DD on ios, so that unlocking thing may be the issue.

1 Like

No joy. :frowning: I started the dji go4 ios app, tapped the checkbox about geofencing and clicked Yes, and could fly with no issues.

Landed, stopped and killed go4 app, started DD, exact same error: Plan upload failed: there is not a mission available.



Was the flight plan generated on the DroneDeploy interface or an imported KML? PC or tablet?

It was generated on a PC via the web interface. I forgot to mention that I swapped out the ipad for my android phone, and of course I couldn’t test the missions I want to fly because they only work in ios (video and pano). Grrr…
But the missions that work on android, worked again today, with the usual caveats (start azrecorder, set usb to file transfer, close everything else, open bitwarden for login creds, copy/paste creds into DD). I didn’t have to first start go4 and accept the consequenses; it just worked.

I’m still having this issue (tried again today), so I decided to email support, even though I’m on the “explorer” plan. I actually got a pretty timely and worthwhile response!

"We have had a few other users reach out about this same issue today. We have escalated to our flight team to see if there are any commonalities or if we have a bug.

Can you please confirm the DroneDeploy app version you were running at the time and the name of the project?"

I responded, so we’ll see where it goes.


I attempted a DD flight at home this weekend, where there are no geo-restrictions of any kind, and got the same error. I emailed support for an update and got a reply this morning that they’ve made no progress on this. So at this point the IOS DD flight app is dead in the water and useless, at least on the only apple device I have access to (ipad 7th gen).

Is anybody else able to fly with DD on their ipad currently? If so, what ios are you using, and what gen ipad?

(I can use my android devices, with the caveat that I can only fly mapping and picture missions; no other mission types work on android, which is a known issue.)

1 Like

I flew two missions yesterday and two this morning so far without any issues. You might want to go through all of the diagnostics for your drone and recalibrate everything including the vision sensors. I would do a lot of rebooting to the drone too. Make sure you are outside when doing anything with the compass or GPS involved. Also if you haven’t already try reinstalling the DroneDeploy’s app.

1 Like

I don’t think it’s going to be drone related, as this isn’t an issue when using an android device. (I could be wrong, of course.) But reinstalling DD is a great suggestion. I may reinstall the dji go 4 app as well, just for a fresh slate.

But support says others are having the same issue, so I hope they find an answer soon for those like me with this issue.


That’s a great idea. Uninstall both. Get it booted and flown a few times with DJI to see if you get any updates then install and try DroneDeploy. If you don’t get anything in DJI and it flies then great, but if DD still doesn’t work then it points towards a bug in the software with you specific setup. We just need to find more people with the same equipment. That’s all DD is going to do.

1 Like

Yep. Unfortunately I won’t be able to test until tonight; didn’t bring the drone with me to work today since it’s going to be raining sideways most of the week up here in NorCal! Hopefully I can catch a break long enough to test at some point this week, but I can certainly get the ipad prepped and ready.

Support does have other users with the same issues, but I’d love to here of anybody else getting the same error, and a list of the equipment they’re using.

Again, I’m using a Mavic Pro, an ipad 7th gen, ios 15.1.

Are you using an ipad, @MichaelL? If so, what bird are you flying, what generation ipad, and what version ios?

1 Like

There have been some goofy things emerging with the version of DD and v15 of iOS besides this. We run our iPads with P4P’s on Mini 5 devices. On the drone side the slightly older Mavic Pro could be having issues communicating to new code. Anyhow it usually depends on the person’s individual configuration of equipment. This is why we push for user beta testing because there is no way their staff can encompass the number of setups that are out there.

1 Like

Maybe a stupid question, but…does the go4 app need to be installed in order for DD to work? I’m guessing “yes”…

Not necessarily but it’s recommended because it does pick up things that DroneDeploy can’t see and you might need it to unlock occasionally.

Gotcha. Well, I deleted both go4 and DD (and the Autel Starlink app just in case), updated to ios 15.2, re-installed just DD, and…same issue.

I then installed the dji go4 app, flew with it, then closed it and tried DD…same issue.

Will email this update to support.

Oh; my camera was slowly drifting all around while sitting on the ground, and then the bird was yawing all by itself in the air. Landed and attempted to do a compass calibrate, but that failed, even though I was nowhere near a car or any metal / magnetic surfaces. I’ll try to calibrate it tonight at home in my back yard. Sheesh…

The compass calibrated just fine at home last night; as soon as we get a break in the rain at lunchtime I’ll try it again.

Got an encouraging update from support last night:

“This is a high-priority case that we are working through and trying to replicate and find a solution. I will continue to let you know when we have any updates.”