Plan failed to upload

Hi, I am using a phantom 4. I am asked to create an orthoimage so I decided to use drone deploy. I created the flight plans and everything. My P4 is set in P mode flight. The drone connects with the app on my iphone 11, it goes through the check flight list without any issues. And when I click on start flight, it says “Drone initializing” but then “Plan failed to upload: cannot run in the current mode etc switch to appropriate mode etc P mode”. I restarted both RC and drone several times. Closed the DJI GO APP while using the dronedeploy app, but made no difference I cannot fly the planned flight.
Any suggestions will be appreciated so I can finish my work.



Which model of Phantom 4?

Is it just that flight plan?

Did you try flipping the Mode switch while on that screen?

I only tried that flight plan, yes I tried flipping mode switch while on that screen and it will tell me that I had to switch back to P mode…but still couldn’t start the autonomous plan.

It’s the regular phanton 4

1 Like

At first I was thinking that the P4 Standard wasn’t supported but it is on their list. It still could be part of the problem though as it is a different remote. Something easily could have changed in the DD app firmware that would cause something like this. The only thing I can think of is to make sure the firmware for both the aircraft and the batteries are updated.

@Anjanette_Hill @Andrew_Fraser Have you heard of this recently? I remember it happening in the past but it was with Mavics and Inspires and I have never seen this specific error.

1 Like

Yes done that, firmware is updated. Still the issue persist. Even tried to create a new plan as the drone was connected and try to fly it but nothing, same error message.

What mobile device are you using?

I’m using an iphone 11