URGENT! Can't access missions / folders on iOS


#1

Summary of Issue:

I planned a number of missions for field work in Vietnam, where I am at the moment. The drone belongs to my University Department and received a firmware update, which forced me to update DJI Go and Dronedeploy. Due to a tight schedule I had no time to test the setup before travelling out here and now I am stuck: Drone Deploy will open and work fine as long as it is on a WIFI network but since I will be in places without WIFI / network I have to rely on Dronedeploy’s offline mode for many of my surveys.

Here is the problem: as soon as DD is offline neither missions nor folders will open (yet other elements work, so the app has not fully crashed). Reconnecting to the network will not remedy the issue and I have to force restart the app. I selected use offline.

I am using a Mavic pro and iPad Pro 1st gen 9.7", all up to date.

Tried: restart, remove third party apps, re-install.


#2

As a backup you might consider DJI GS Pro on the iPad. It flies autonomously like the DD app.


#3

Hi @Thorsten.K,

Thanks for swinging by the DroneDeploy Forum to report your issue. Can you share the email address associated with your DroneDeploy account so my team can investigate?

Keep me posted,
Christina


#5

Hi,

T.kahlert@qub.ac.uk

Thanks for looking into this.


#6

Thank you @t.kahlert. I’ll report back once I have more information to share or if my team needs more information about your issue.

Please note that since it is a holiday this week so responses and investigations may take a bit more time than the usual.

Cheers,
Christina


#8

Were you able to set them as available offline while on wifi?


#9

Yes. I downloaded them and the missions I need to fly are all in offline mode. But as soon as network connection is lost these missions cannot be accessed anymore.


#10

Headed to set one of my maps and go to airplane mode. Be right back.


#11

I just tested offline capability and it appears to be OK with this app version. Can you hotspot from your phone or another device? Can you test plan a flight while on wifi coverage?


#12

Just to provide you with a bit of context, I am currently working in Vietnam and only now received a SIM card. I am now in a tropical limestone forest. While I have good reception now, this is probably not always going to be the case.
It seems that as long as i am online everything is working and only stops once I loose connection. I can tether my iPad to my phone where there is mobile coverage. Due to the topography the number of potential launch locations is extremely limited and I have to rely on DD’s offline function.


#13

Hi @t.kahlert,

Thank you for being patient during this time. My team been unsuccessful in reproducing this issue, and it may be difficult to reproduce as you are in a remote area, which can be a culprit. We will continue investigating the matter but we do not have any workarounds to share at this time.

Cheers,
Christina


#15

Hi Guys,
I had similar problems in the Antarctic last year (probably as different from the jungle of Vietnam as I can imagine!). I may not understand your problem exactly (apologies if this is redundant), but there are a few things I did to correct the issue for offline flying (and DD has improved the app as well):

  • plan your flights online via the desktop/web interface
  • log out
  • while still in wifi range, log in with the tablet/app and let it update with the new plans
  • select the “make available offline” button for each flight
  • log in and out once more with both the tablet and the desktop.
  • I also leave the app open on the tablet

This seemed to work. The multiple log in/out seems to put the tablet/app in sync with the web portal and maintain offline access. Hope that helps.
A.


#16

Hi, I’ll try that. Luckily, I was not without internet connection so far. I always plan my flights in ArcGIS and then upload to DD web to sync to DD iPad.


#17

Hi @t.kahlert,

I wanted to follow up and see if the suggestions by @Thunderflurry worked out for you. My team has still been unable to reproduce the issue since we are not in a location as remote as you are. :confused:

Keep me posted,
Christina


#18

Hi Cristina,

I am doing OK, thank you. I was not without internet connection so far and this didn’t have to use the workaround. But thanks for the follow-up.

I would be more interested in finding out as to why this happens and why your tech team is not able to replicate the issue.


#19

Hi @t.kahlert,

I don’t have any info to share at the moment but I’ve asked my team for an update to share with you. I’ll let you know as soon as I get a reply.

Cheers,
Christina


#20

Hi @t.kahlert,

Late notice, but better late than never, right? Our team patched a bug that caused this issue to happen recently, so what you were experiencing was definitely not expected or intended behavior. We’ve since fixed the issue in latest app releases so if you continue experiencing this please let me know.

Cheers,
Christina