Error: Mission building failed with DD v2.78.0


When I attempt to start the pre-flight checklist to upload flight plans to my drone, I get the error “Mission building failed” at the final step of the checklist. I’m wondering: Has anyone else seen this error, or have any suggestions? I believe it is a problem with DroneDeploy v2.78.0, which is the latest release at this time. My flight plans are all showing as ‘Available offline’. I have reported the problem to DroneDeploy chat support, and they say their engineers are looking into it.

This problem showed up after I updated the DD software on 8/22/18; I wish I could go back to the previous version! I’ve had 20 or 30 successful DD flights before this.

Here are the steps I have tried, all with the same error result:

  • Restarting the drone, the controller, and the iPad many times.
  • Creating new flights on the iPad itself
  • Deleting and reinstalling DroneDeploy
  • Installed DD on my iPhone and attempted uploading flight plans from there
  • Attempted while connected to Wifi and while offline, in airplane mode

Here are my specs:
Phantom 4 Pro (not v.2)
Aircraft firmware: v1.05.0600
Controller firmware: v1.04.01.00
DD v2.78.0
iPad mini 4, running iOS v11.4.1 (I also tried my iPhone 6, running iOS v11.4.1)

Thank you,

Here is a screenshot of the error.IMG_2927

I have discovered that when the planned flight’s location is farther than about 3.8 miles from my present location, I get the ‘mission building failed’ error. If I drag the flight plan slightly closer and try the preflight checklist again, I don’t get the error. Strange.


Hello @mbarney, thanks for reaching out.

I have escalated your request to our engineers and I will be following up via email. As far as a workaround, have you tried to planning/flying the flight with an internet connection? Thank you and I hope we can resolve this issue as soon as possible for you. Thanks!

Hi Yusuf,

Yes. I just tried it again with a new flight plan, with the controller connected to the internet, and got the ‘Mission building failed’ error again.