Phantom 4 DD android latest release still wont connect, help please

Phantom 4 and new release on android wont connect.

Hi im at an end, i cant work out what im doing wrong, i have the latest firmware and updates, i close the dji app, checking its closed on the tablet, then open the DD app.
App work fine but after planning the mission it says connect a drone? ?

At this point im lost as it was previously connected on dji.

Can anyone spot my mistakes or offer help?


When you connect a drone successfully. It will say “drone connected” and it will show it on the map. Are you seeing that before planning?

After closing DJI go try unplugging and plugging in the USB. Does it ask you which app to use after you plug in the USB?

Andrew I found I needed to go into my application manager and clear my either Go APP or Drone Deploy under Default Apps to use the other. Checking that the app was closed wasn’t enough. It doesn’t ask if you want the app to be your default but on mine it automatically puts the last app in as the default and the other app wont hook up without clearing the previous. Also I pull the USB out of the RC before clearing the app. Seems to work now for me.

Ahhhhhhhhh the usb!!! I tried another app due to the phantom 4 not being supported and i didnt need to hard wire connect.
Now that may make a difference, i am yet to find any info in the instructions i can find. I am i missing a pdf instruction sheet any where on DD site?
Ill give it a crack​:slight_smile::slight_smile::slight_smile:

Thanks for the help

Ill let you know the outcome

Got it working, fantastic, just ran a couple of missions today and turned out great. Now to find the optimal flight height!


Hey crunchies69, Im having the same problem you described. Using Phantom 4 with updated P4 firmware from this morning, the latest DD release 2.0.4, and an Android Nexus 5x. But after making a flight plan DD reports “connect to drone” and will not connect. I tried pulling the USB cable and clearing the DJI Go app as well. No luck. How did you finally connect to the drone?

Any help appreciated. Im excited to make some maps!


DD works well on the Phantom 4, I’m using a Galaxy Tab2 9.7 inch, I’ll run through my set-up procedure set by step, sorry if is a bit anal!

  1. Turn on the RC then connect your tablet or phone.
  2. When it connects it should give you the option to connect either DD or DJI app, I don’t haver them set as default, if you do clear it.
  3. Turn on the Phantom and get it connected on the DJI app, I let it do its gps connection etc.
  4. Close the DJI app then check the all apps open and close again! Then unplug the usb and plug in again.
  5. The tablet will give you the option again ( hopefully) to select either DJi or DD select DD.
  6. Select your pre made flight plan, if you have done one. I have found they don’t always save when doing it on the tablet, no hassles though.
  7. If your happy with the altitude and plan on the bottom left of screen you should see Drone Connected… .hopefully. Then on the bottom right a blue symbol, sorry cant remember what it looks like.
  8. Hit the blue bottom right symbol, it should then go to preflight check, if so your winning!
    9.Once all the ticks have been ticked then its ready to fly with I think a plane on the bottom right corner. Hit it and the Phantom motors should arm and off you go!.. hopefully.

One thing to remember is the mode switch if it isn’t in P for normal flight there will be a error shown on the left of screen. I also take control of the Phantom when its getting close and land it myself.

Good luck let me know how you go, all flights I have done so far have run perfectly
Thanks Drone Deploy!


1 Like

How did it go any luck with the tips below.?

Hey, wow that was cool. The key steps you identified were #4 and #5. I must have been connected to the DJI GO app previously therefore DD was not able to “connect” to my drone. I found in my phone where DJI GO was set as the default app for the drone. I cleared it from being default and now it asks me which app to use when I unplug/replug in the phone/RC. Worked like a champ. Thank you for the assist! Cheers!

Hi all
I have similar issues since a couple of days with both Nexus 9 and an iPhone 6s device. No matter which order I follow to connect I can not start missions.

But on both devices the app tells me that it connected to the P4.

DJI Go works fine.

What I noticed is that even DD is running on the Nexus 9 it’s not listed under running Apps.

  • App tells me: 'Drone Connected
  • App even shows me battery status
  • App is not able to locate drone on the map
  • Missions can not start
  • Positioning with DJI GO works fine

Hi Martin,

From our logs it look like you were able to fly today. Did you resolve your problem?

Hi Chase
In the morning, I have no idea what went wrong, I had no chance to connect DD to the P4.
7 hours later, using the same hardware, it worked just fine…

:frowning: worst type of bug

Hi, I’m having a similar problem. The app is saying drone connected at the bottom of The dash board. But when I click the save icon after creating a new flight plan, it says, “your pan has been saved, connect a drone to fly”

Using nexus 5x and phantom 3 advanced

Also, ever since installing DD, dji go app continuously crashes!

Sorry about this- we recommend the following:

  1. Recycle the power on your tablet or phone the app is on.
  2. Turn on the drone and open the DJI GO app to calibrate the compass.
  3. Quit the DJI GO app.
  4. Recycle the power on the drone and the controller.
  5. Open the DroneDeploy app.

Uninstall the DJI GO app from your device, and re-install when you need it, and everything will work fine. The two programs, running with the latest Android update, don’t play together at all.They cannot exist on the same device regardless if they are running or not. I believe it involves the USB drivers that are not compatible.

Having both installed on the same device will work great most of the time - but certain situations, when done in a certain order, will disable commands to the camera, the shutter, and the low battery/return to home command. I suspect others - but I haven’t found them yet - and not willing to fly with both installed and risk it.

I use two different devices to fly with. It’s a pain, yes, but I don’t suspect it will be forever.