Connection Problems to P4Pro

I have connected my RC but I can’t get my aircraft to connect to Drone Deploy… I suspect I’m not quitting the DJI app successfully? I’m using an i-pad mini, any suggestions? I have updated all my firmware and have multiple flight modes on…and I have the latest version on DD. Arghhh first job booked and conditions are perfect…HELP

Sometimes it takes recycling power on the drone and controller a number of times to connect. Make sure the DJI GO 4 app is slid off the screen prior to opening the DD app. You might also close and reopen the DD app.

If it is not getting enough GPS, I find it helps to close the DD app and open the DJI app. It seems to get satellites easier. Then open the DD app.

Thanks Gary. I have tried just about everything from hovering using DJI Go and then closing & connecting while in the air. Unplugging the cords…reinstalling the app, still no luck after nearly 5 hours yesterday. Might be an issue with my controller as it’s brand new, I shall check the configuration thoroughly today, although it’s flying perfect in DJI Go. Must be something I’m overlooking. Cheers Sonia