Problems connecting P3 Adv with new app version

It seems I can’t get my P3 Adv connect with the app anymore, although everything is in it’s latest firmware.

I’ve done the initial procedure within the DJI Go and closed it. Changed to “F” position. Opened the new DD app, planned a new mission, but the Fly button wasn’t shown.

I’ve checked if there was a SD card in the drone.

I can’t see what might be the issue here. Any help?

We’re improving a bit of the messaging when connecting the drone.

Make sure DJI Go is closed if this is an Android device.
Try different USB cables.
Uninstall and reinstall app if nothing else works.

I also wasn’t able to fly with the new app. P3 pro. It kept defaulting to San Francisco area on the map. I uninstalled the app and reinstalled and had no more problems.

If you connect your drone, the map should update to the location of the drone. The only time I think it goes to san francisco is if you start a simulator. Can you explain the steps you’re taking?


Chase Gray

Turn on transmitter first and then drone. Then open drone deploy app.

After deleting and reloading the app I havn’t had any issues. The only other problem is when I change locations and plan a new flight I get a message during the safety check saying that 2 consecutive points are to far apart. If I go back and delete previous flights it seems to work ok. Is there something I should be doing between flights to eliminate this?


I have a P3 pro and have done everything you guys said it just wont connect with the upgraded app. no connection - have deleted the app and reinstalled. dji go is closed everthing. worked perfectly with the old app. firmware of the latest. android. can anybody please help

Hi there,
Just tried to reinstal everything and it is not working on android tablets and smartphone
We cannot automate flight anymore, just saving the plan
Is there a way to come back on the oldest app?

Hey. I sent each of you a PM.

I have a P4 and can not get it to connect to the app at all. I have tried every thing above comments have stated and still nothing. I am running the app on a samsung galaxy note 5.

I chatted with some of the users above and it was always an issue with DJI go being open or having control of the USB instead of

i’m having the same problem, the only way i can get my p3p to connect with my samsung galaxy s5, is to uninstall the dd app, then force stop the dji app, then, re open the dji app when it asked “use this default usb setting”, say yes, then at least i can fly the drone, but as soon as i install the dd app, it will not connect with the drone, any suggestions? interestingly enough, after i install the dd app, when i do try to connect with the dji (it wont let me connect), if i swipe down it has 4 options for the usb port, battery charger, mpt, midi, or tpt i think, i’ve tried each one of those settings and nothing has worked

You shouldn’t ever say use as the default app. That will cause other apps to not work. If you do that you will have to go into the application settings and clear the defaults.

Got a similar problem, the app tells me “Drone connected” but when i plan a flight only the “save” button appears…Had to uninstall the dji go app to even connect the drone :confused:

Hey, @chasemgray, I did not received your PM. Could you help me as well?

After the latest firmware update I tried everything again, but I’m still not able do connect my drone. I’ve treyd to unnisntall everything and intall again

In every test I do, I make sure DJI Go is closed. Had tryed several cables. I’m using a Samsung Tab S.

I did manage connect the drone with other apps (altizure, pix4d capture and data mapper inflight) using this device.

I did another teste using the IOS drone deploy version using a borrowed Iphone, and the drone connected without a problem.

Felling really lost here.

I solved my problem with this tip

Great!:thumbsup: glad to hear that!

On android Lollipop versions later then 5.0.1, one is not given the choice at the trigger event. One is FORCED by android to make that app you choose then the default. There is no other way to have the app capture the USB port than to choose it at the initial event. One must clert defaults manually with settings. Please let the idiots at Android know that this is not satisfactory. We want the choice. I have no clue as to why these fools have taken a choice away from you, but they did!

This is a little off topic but I have all of the newest software and firmware updates on my Android device and on my Phantom 3. I planned some flights and connected with the Drone deploy app perfectly and then the PreFlight checklist and everything is ok. When I go to press the check mark after the PreFlight checklist is finished I get an error message saying the “radius of the mission is outside the acceptable limit.” I made several other plans with several other fields that are larger and smaller and the same error is occurring. What does this mean and how can I solve this issue?

Hi @A.G.I.S - please check that you have not specified a lower radius from the MC settings in DJI GO.

Hi Chase got the PM and it looks like its the default thing with me too. Do you know if there is any other way than having to clear the default app every time?