P3 Won't Connect - DJI Go Won't Work

Alright - I’ve read several threads on almost this same topic, but I have yet to find a solution, so y’all are my last shot before I give up on DD completely!

I’m trying to use DD with a P3 (firmware is up-to-date, connects and works fine with DJI Go) and an HTC One M8 phone (running Marshmallow 6.20.502.5, USB cable works with DJI Go).

I, for the life of me, cannot get DJI Go and Drone Deploy to co-exist. DJI Go works excellently on its own, but as soon as I download and open DD, DJI Go becomes very tricky to work with. On the DD side, I cannot ever get past “Connected - Waiting for Drone”. A small box showing “Drone Connected” will pop up for a moment, but then clears and leaves me with “Waiting for Drone”.

I know the obvious answer is to make sure I’m not using either app as a default, but I am not. After verifying the drone is able to work through DJI Go and when switching to DD, I close the DJI Go app, unplug the USB, do a force stop on the app, and ensure any defaults are cleared. After all that, I still get nowhere with DD. Then, when trying to go back to DJI Go through the same process, DJI Go will not connect to the drone until I’ve DISABLED DD. I’ve tried to disable DJI Go when using DD, but that doesn’t help either.

What a pain and how frustrating. DD looks like a great service and tool, but I’m just about at wit’s end trying to make it work. Please help!!

Thank you in advance!

Sorry for the frustrations @BTOM -we’ve been working with DJI on their Android connection for a while now, and are also disappointed to see the difficulty our customers are having on Android 6. It takes some customers multiple tries to establish the connection. No solution other than the ones outlined here, but some customers have had better luck when trying a few different USB cables.

Hi there,

I have the same problem all the time until,

I told the Android APP not to connect automatically to the DjiGo or Drone Deploy APP or any other
APP I use to connect to the aircraft.

Just click on ONCE and not default or all they time.

As there are so many Android devices out there it had to tell you how to setup your device.

It is how you connect to the USB function, check you settings