Connecting Phantom 4 to DD


#1

Is there a trick to connecting my Phantom 4 to DD? It’s just not seeing the craft at all, so I think I must be missing something simple. Works fine with my Inspire1 every time. I also notice that there is no P4 listed as available aircraft in the flight planning software online.


#2

Are you using iOS or android? Android is about to be released with support.


#3

I am using iOS, tried the beta version on one device and the app store version on another. No luck with either device.


#4

Hmm. Is there maybe a mode not turned on in the DJI go
Settings? Multiple flight mode, etc.? It should be seeing the drone.


#5

I will double check, but I just returned from taking the same device out with my Inspire1 and ran a mission. It worked like a charm, so I don’t see how it could be a software setting. Which flight mode is supposed to be set on the Phantom 4 controller? Maybe that’s the culprit.


#6

I solved the problem, didn’t have the latest update on the DD beta. I knew it would be something simple!

Well, I thought I had the problem solved. I went out to fly the mission since the P4 was now connected to DD, but when I went to launch it told me to change the flight mode to F, as if it thought it was an Inspire1. Looked up this issue while I was out in the field and restarted the app a couple of times per the instructions, but it did not help.

I will post again here when I finally get the P4 up and running with Drone Deploy.


#7

It should tell you to use P mode if you have the right iOS app and are using the P4


#8

Do they have different apps for different birds? If so, then that would make sense because I began using this app/device with my Inspire1 a few months ago.


#9

Where are you downloading the app from?


#10

From the TestFlight downloader that was provided via iOS beta test link.


#11

Ah. That’s he problem. We left
Beta a month or two ago and are in the actual App Store.


#12

I was able to execute two missions today with the P4. In each case, the P4 was difficult to connect to the app, but unplugging the USB and re-attaching it was helpful for getting the DD app to recognize the bird. Each mission was successful, however each time the app lost contact with the bird. This did not prevent the bird from completing the mission, I just had to watch it with the binoculars instead of on screen. On the second mission, I asked it to cover too much acreage and got the low battery alarm. I held the return home button down on the transmitter and it came home just like clockwork. All in all, a very productive learning day with the P4. Can’t wait to see the imagery as soon as it’s processed…


#13

Great to hear you got it all working!


#14

Yes, in fact I went out and flew another 80 acre block today with no defects at all in the flight. I started near the middle of the field rather than one end and I think that may have helped maintain the visual link with the iPad.


#15

I have this happen when using DroneDeploy after DJI GO. I have found that if I power everything off. (iPad Mini, controller, and drone) and then it will connect.


#16

Hi Anderson. This thread is 3 years old. Are you still having connection issues?


#17

I haven’t used DroneDeploy for a few months now. But, as of then, yeah, it was still happening. I always check for firmware and app updates before I leave home. When I get to the field I first open up DJI Go to recheck that firmware is current, no compass calibration is needed, check for radio interference, etc. I then close it and open DroneDeploy. Often it won’t connect, so I power everything down and back up and then it works.


closed #18