Cannot connect P4 Advanced to DD "waiting for drone"

Hi, I know that other users have had issues with this but I have not been able to get connected to DD despite trying all the fixes I can find on the subject. I am using a Phantom 4 Advanced with a iPhone6s and have tried all the following with no luck:

  1. Have latest firmware update on drone
  2. Tried with two seperate phones (iPhone 6 and iPhone 6S)
  3. Tried with new accounts for both DJ Go and DD
  4. Tried killing DJ4 before launching DD. (also unplugged USB cable and replugged in)
  5. Tried with a map created in the DD app.
  6. Have conducted all tests outside with up to 15 satellites present.
  7. Have also tried with no other apps running in background

Any help or advice on what else I can try ?

Thanks very much



Phantom 4 advanced isn’t supported yet. Support will be in the next few weeks.

Thank you. Will you put a message out when this becomes available ?

Does this matter with DJI P4 Pro …?
Aircraft icon does not exist.

I’m using Android Asus S500KL

No, if you’re on Android it can be tricky to get connected sometimes. Make sure DJI Go is closed and that you don’t have any default settings on for DJI Go. You could even temporarily try with DJI go and other 3rd party apps uninstalled because they could be conflicting.

I finally got it to work by uninstalling ALL other apps that access the drone: DJI Go 4, Litchi, Pix4d Capture. In fact Pix4d is the only app that will work with DD and DJI Go installed. I think it’s because Pix4d is the only one that requires an additional plugin app call Ctrl+DJI to access DJI drones.
Kind of a pain in the axx if you want to use manual camera settings with DD! Good news is the Pix4d has polygonal flight plans coming - real soon now…

Any update when Phantom 4 advanced supply will be supported? I currently run P4A on iOS. DD ‘works’ but has a bug that the picture location spacing is uneven, and sometimes pictures will be missed altogether. Slowing the time between pictures down by limiting the maximum flight speed doesn’t help. Support for the 2:3 picture ratio, to take advantage of the full 20MP would also be nice.

Do you have some screenshots showing the image spacing?

Also, we have tried to adjust the aspect ratio but due to a DJI bug we see some crazy fpv bugs if we adjust the ratio before the flight.

Screen shot below. Thanks.