No upload button

I finished a short mission and want to upload the images from SD, but there’s no upload button on the dashboard. Any help would be much appreciated.

Kind regards,


That is something that is only enabled by default for users who sign up to fly DJI devices. I enabled it for your account.

Oh I see as I signed up originally with with a 3D Robotics Iris+ and thanks for enabling the upload option.

Hi Chase, I also can not find an upload portal on my dashboard. I thought I signed up as a dji user but might have not. Can you enable that in my dashboard? Thanks!

It looks like you do have that permission. Do you have the flights you made available on your dashboard? The upload button should be either the primary button on the right side or within the dropdown if it says “flight log”

My issue today was kind of like this. This was my second flight but this one was over many acres. flight time 9 minutes. Somewhere around 50+ pictures (I didnt count them). When I returned to my desktop computer and went to dashboard, the flight was there. The flight path is there in white and blue. But it says no pictures were taken, and it will not let me upload any to that flight.
What did I do wrong?

Checking on this now. Sorry for the delay.

Well, I dont know what to say. Today the upload photo button is there. Thanks for all the help guys. I am very impressed with the team at Dronedeploy. Always get an answer back when a question is asked. You guys/gals rock with your customer service and support.
Thank You

1 Like

I just made my first two flights using a Phantom 3 and went to upload my photos, but I also can not find the upload button. Does mine happen to be non activated as well? Any help would be much appreciated.

Your account didn’t have that permission for some reason. I fixed it.

I am also having the same issue. I have a button that says synced, but I can not upload pics from the SD card from an Inspire 1 mission.

You may have to turn your app back on so it syncs when online. There is a message after you finish a flight that has the instructions. We’ll add some more on the desktop app soon.

I signed up today, I also have no upload button on the web app, only on the app (clicking it says “Sorry, we don’t support uploading on a mobile device”). I have a DJI Phantom 4 but there was no question about which drone I use in the sign-up process.

Can you send an email to with a screenshot of where you are not seeing the upload button?

I am having the same problem. I got an upload button on my tablet but got the “Sorry, we don’t support uploading on a mobile device” message. Went back to the app dashboard then closed the app. Re-opened and the the flight synced back to not flown and the edit button. I’m trying the manual upload on PC but would like to have had this flight saved and marked as complete. Should I have done something different on the tablet?

I usually end up uploading the files manually to a “NEW” project name and delete the old, not flown project in the app. I agree that they mobile app and PC app should talk a little better, but honestly for me it is only a slight increase in time.

I face same issue as Joao with my DJI P4. States doesn’t support uploading on a mobile device and I have searched in vain for a desktop solution to upload with no success. The upload button shows on my app and worked in earlier versions of the app. JIm

Interesting. Since there was no posted explanation or solution mentioned in the forum for the non-support for mobile upload issue, I sent my query to Drone Support. They replied I should connect to manual and to the forum. Circular process at work here. jim

Hi @James_Filgo,

I see Gary from our Support team helped you with your uploading questions and saw in your account that you have successful uploads.

(To help others who may read this)
Unfortunately, uploading pictures from the mobile app is not supported and has to be done through a desktop browser.
Below is the article that explains how to upload pictures from a planned mission:
How to Process Datasets

I also cannot see the upload button , can you please enable it on my account