No Photos taken during mission - Mavic Pro

Have Mavic Pro with latest firmware. Ran 6 acre mission and it flew perfectly.

Upon completion of last waypoint, Mavic Pro flew back and 6 ft above home point. Would not land until I switched over to DJI Go 4.

Proceeded to take about 300 more POI photos on the next battery with DJI GO 4. Camera worked great, images look great.

Came home, opened SD card and noticed there are no pictures from the actual DroneDeploy flight.

Latest iOS version, iPhone 7 Plus
App version 0.0.63-2.0.19

I don’t have a Mavic but I often have problems with DD not taking images. It appears to begin taking images until it loses connection with the controller and reconnects then it doesn’t take pictures. It just flies the route. I bought new sd cards, hoping that was the problem but I still have this problem.

Thanks for the reply. I’ve searched around and noticed others have this same problem with other drones. But, I haven’t seen any solution. This was my first time using the app so I wondered if I failed to set something correctly in the app. I watched several tutorial videos and I didn’t see any settings that would indicate you can even turn the photo function off.

My first couple missions did great.
I’m hoping there’s a bug that will be fixed in the next update. Meanwhile, I installed an ARGtek antenna to try to improve the signal and see how it works. My intentions are to try a smaller mission and keep connection, then try one where I lose connection through the entire process to see how it works out. Let me know if you come up with any solutions.

DJI has finally improved how 3rd parties can trigger the camera. Right now it’s only supported in the upcoming P4 pro dronedeploy support but hopefully they update the flight controllers on P4, p3, etc. soon.

I forgot to mention in my reply that I had a constant connection the entire time. I was only mapping a 6 acre area. I am going to go back to the same area tomorrow afternoon and try it again. I’ll try it on the iPhone and then iPad as well. If it doesn’t work I’ll try a mission with the new DJI GS Pro.

Update: Flew same mission again this afternoon, this time using an iPad Air 2. No problems, I could see picture count going up and a small screen in the upper right hand corner showing the live view with photos being snapped. Changed the mission up slightly (but over the same general area) for the next test. Upon auto take-off, I immediately got a warning indicating that DroneDeploy wasn’t able to trigger the camera, and to manually trigger the camera to start the photoset. I quickly pushed the photo button and it operated fine after that.

It was very bright out and I don’t have any ND filters yet. Photos are overexposed but I can work on that…

I have sort of the same issue. My DJI 3 flies the route perfectly and comes home and lands. It starts off very well and takes about 11 images, then the camera tilts upwards and doesn’t take anymore photos. When I refocus the camera downwards it just gets pulled up again and stares into the distance. Only 1 out of 4 mission flown with DD was successful (image wise, flight wise there where no hassles)

Anyone found out what might be the problem here?

We’ll have to wait and see if they fix the issue in a future update. Problem with how the app triggers the camera.

UPDATE: I just formatted the SD card through the DJI GO app and it started taking all the photos again in DD. Worked for me.

One thing that is often overlooked when using a new SD card is to format the card in DJI GO before you use it to capture images in DroneDeploy. Also it is important to make sure that the camera image is on the left side of the screen and counting images while the mission is taking place. The camera view in the top right portion of the screen that shows you the pictures being taken during the flight is also important. If either of these two features of the app are not showing up I would recommend initiating an RTH and recycling the power on the drone and the app.

there is also a small glitch sometimes during multiple battery flights that requires you to restart the app between battery swaps. This isn’t always an issue but I figured I would include it in this post.

Happy flying!

Thanks for the tips. I think the problem is with the software most of the time. I’ve tried all the other “fixes”, format sd, different cards, fast cards, i.e. There seems to be a problem with the way DD is able to control the camera. I was hoping for a fix this update but it doesn’t look like that has happened.


I have flown about 10 missions using my P3 Standard. I have my SD card formatted and the most current firmware. 0 flights have taken any photos. My P3 will fly the path perfectly but does not take any photos. The live feed has the camera point straight out. If I try to point it towards the ground, it will reset itself to go back to horizontal. Not sure what to do…

The P3 Standard is not as reliable as the other models due to its wifi connection which we use in order to activate the camera.