New DD-APP version on iOS ipad crashes - How to downgrad?


this morning i updated the app via appstore on my ipad with iOS 9 and Phantom 4. But the DDapp shows many errors. Now i want to downgrad the DDapp as soon as possible. Please help me! Is this possible?

I don’t know that you can downgrade the app. What version of the app does it say you are using in the settings page? What are you doing when the app crashes?

Hi Chase, we have been having issues with our inspire 1 since the DD app update, the aircraft will fly the mission but none of the aircraft status info will show in dronedeploy and no pictures are taken. All the aircraft / peripheral firmware are up to date. Using an ipad mini 2. It worked fine before the last DD app update, how can we downgrade the app?


The most concerning part is that none of your status is showing within the app. i don’t think anything that has changed would affect this. Are you sure it’s related to the update? A lot of times we don’t change things but issues with the drone, etc. are associated with the fact that there was an app update.
Is the drone flying correctly with dji go? Have you tried a waypoint mission in DJI go and seen any problems?

So we have tried dji go and map pilot and they all work fine, photos captured and everything. Its definitely just the last dd app update. Can you help me downgrade please?

Ever since the 2 recent updates, iOS DD with my Mavic crashed almost every single flight (started fresh with only DJI Go and DD opened, without any connection). Now I need a lot more batteries to re-map the crashed areas. Even when I tried to resume the mission by reopen DD again after it crashed, the camera doesn’t point down nor take picture. And seems like my iPad mini 2 get a lot hotter than before. DD used to be so much more stable than this. my DD version is 2.0.45.

Somebody please do something about this!

When it crashes is it restarting automatically or is it just closing completely and you have to tap the icon to open it again?

it seems fixed with the new updates :+1:

I am having the same problem with the latest version of DD app and Ipad Mini 2. No applications are running besides DD but it will crash at least once per mission, sometimes twice. Back of the iPad gets extremely hot as well and I am in the shade. Photos seem to continue to be captured, but the drone will never orbit.

This has happened with every flight since I upgraded to the latest version of the app. Flying an Inspire 2 with 5S lens on missions not longer than 10-12 minutes. This morning my flight time was 12 minutes, app crashed twice and hovered in the air over the last recording spot on the mission. I had to hit the home button more than once and it did fly home but wouldn’t land, just hovered again.

Hi, do you happen to be running fieldscanner on any of your flights?

It also doesn’t seem that you’re on the latest version. Can you upgrade and let us know if it’s still happening?

I am only running the DD app on my iPad. I don’t know what fieldscanner is. Is that something from the marketplace?

The one that just came out today? No, I wasn’t on that version, but I have upgraded and I will try it again.

Be sure you are also using the latest iOS. We had the same issue with the new DD app until we also updated the iOS on the iPad. Unfortunately, not all versions of the iPad are capable of being upgraded to iOS 10+ but if you can, the latest release of DD fixed a host of other issues we were having previously so it’s worth trying to keep it installed.

I downloaded the latest release yesterday and I can say that did not make it better at least in my experience. I am also fully current on my iOS versions too. Only apps I was running was DD again but I went to the same field I have been trying to capture and got the following:

  • Started up fine and drone took off to capture images - almost immediately I could feel the back of the iPad heating up. I was outside, but covered by shade.
  • about 4 passes into the run, DD shut down unexpectedly, but the drone kept flying on it’s seemingly correct path.
  • I started the app again and was given the option to resume. When this happened, the battery indicator on the app showed red with only the % sign which should indicate my battery was dead, but this wasn’t the case. Fresh batteries and only a 13 minute flight not even halfway complete.
  • Finished the mapping area and the drone just hovered over the last plot. I waited for a minute and then pressed the home button.
  • Pressed the Home button several more times and then it finally started home.
  • Drone hovered over the home location but did not descend. Again I waited for a minute.
  • Hit home again several times and it started to descend. By this time the back of the iPad was very hot.

I put the drone and iPad mini in my car, with the iPad laid against the AC vents until it was cooled off. Then I rebooted it and drove to my next planned mission location.

Tried to fly another mission, but the app would connect, then disconnect from the drone repeatedly. I restarted both the drone and the controller but this kept happening. I downloaded the files to be used offline and tried again but by this time the back of the iPad was so hot, it wouldn’t finalize the last item on the preflight checklist so I decided to abort.

I don’t feel comfortable putting my Inspire 2 up in the air with this version of the software. Please let me know if there is anything else I can check.

Thanks for trying on the new release. We have some new crash monitoring so we can see what is happening on your ipad. I’m hoping that it helps us figure out what is happening for you.

Started the mission. Finished one battery but not the mission. Loaded a new battery but was not allowed to resume mission. Started over and re flew mission. Finished one battery but not the mission, changed the battery and was allowed to restart. The drone took off and headed for a different part of the planet. I was able to get it home and was given the option to resume. Drone rose to maybe 25’ and headed a different direction.
Same issue as others - expecting my iPad mini to burst into flames, app closing itself 2 times in 12 min flight.

Is that something I need to send you or will the app automatically send?

Update - Flew again today and the app connected, flew the mission without crashing and even orbited. The only problems were:

  • The battery still shows red with % indicating battery issues, but these were fresh batteries at the start of the mission.
  • No photos were taken… Kinda a big deal and a waste of my time.

Update #2 - Installed Drone Deploy on full size iPad and went to the same location. The mission started fine, battery indicator was correct and it started taking images. So far so good.

Then on the last leg of the flight, the app said that the drone had “deviated from the expected flight path and may need to be brought back home”. I watched it fly out to the end of the run and hover. Pressed home and it came back.

Once it had landed, I pressed Continue on the App, which seemed to accurately show the remaining run to make. Drone took off and flew to the correct location and started taking images again. It was about this time, my iPad gave me a temperature warning and said I had to cool it off. Now, the ipad was in the shade the entire time but it is 88 outside here now - heat’s a factor maybe?

I ran the air-conditioner trying to cool off the iPad but the Drone started coming home on it’s own anyway, thankfully. Something is either causing the iPads (2 completely different ones) to run too hot that it impacts processes or else there is just a temperature range that makes using this software in the middle of the day in summertime hit or miss.

I do know that I have run this successfully in the middle of the day in nearly the same conditions without any problems (crashing anyway) so my only guess is that there is something with either the latest DD upgrade or the DJI firmware update.

Started Sitting in the air conditioned truck. Helped a bunch. Flew 450 Acres yesterday with an iPhone 6s with no problems… 96 degrees outside 70 degrees in the truck. I’m thinking this is an iPad issue not DD. I am nervous about radio signal in the truck so will be searching for the external antenna option,

You may be right. I’m thinking it is DJI’s latest update more now. When flying, I get a message that the CPU of the mobile device is maxed out. This is without using DD or any other apps/ all caching disabled. There are lots of posts about this error, diminished performance and over heating on the DJI forums regarding the latest update. In both Mavic and Inspire forums.