Issues with new app version and Phantom 3 Pro

I went out today to try the new app version on a mission. Flew with the old version on Monday with no issues. I setup the mission in the office and was able to sync it to the ipad with no issues. Got to the field and pulled up the mission and started the flight. The Phantom 3 Pro took off and got about 100 feet off the ground and then the app comes up saying that the mission is completed and to upload my images. I landed the drone and restarted everything and tried again with the same result. So next I tried to create a new mission and the same thing happened again with the mission that I created in the field. The last time I just let it go and the drone did fly the mission but I did not have any information from it while it was flying. I also tried the mission that I created on my Andriod phone. Using my phone the drone took off and started the mission but it would only fly at 6mph. I am using a Phantom 3 pro with the latest version of firmware 1.08.0080 and an Ipad air 2. Does anyone have any ideas to try. I need to map some fields. Thank you.

Hi Robbie,

Sorry to hear you had this issue. We’ve identified the cause, and pushed a fix this evening.

The Android version is already live, and we expect the iOS version to be in the store by tomorrow morning.

Thanks for the patience, and for reporting the issue.


So !
I flew the V2.0 this morning without desk preparation.
Really new and nice interface, more parameters, easier to tune. Still missing the bird speed I think
But camera, height and others interesting parameters ok
No crash, fluent flight datas informations except when landing where the height jumps from 8 to 8 meters down.

That time and it never happened before, no problem to connect DD and the bird, connection ok without needing a cold start ! Good !
I didn’t check if all pictures are ok, let see after processing.
Oh, one thing still not good: there’s no way to stop/quit the App except killing it …
More infos after processing but you made a good job, continue !!

After processing, pretty good result.
Note camera is labelled as P3P, what it is, but the bird is labeled Inspire, what it is not …
No picture missing, fine job.