Issues with 0.0.28-2.0.4 on IOS


I was using the latest release on IOS with a P3 Pro today and encountered various problems.

First set of problems.

  1. Initial flight planning worked but some of the white buttons got “left behind” as the screen scrolled. Restart didn’t clear it, but eventually the problem resolved.
  2. Launched aircraft but it didn’t spin up. Hitting Home button on app made it think it was going home.
  3. Restarted a few times, eventually ended up with a numerical error when trying to upload way points. Eventually determined that the IMU required calibration. The IMU was fine when I checked with DJI Go ten minutes earlier, and the home point was correct when building the initial flight plan.
  4. Recalibrated IMU, flight #1 worked as expected.

Flight #2

  1. Planning appeared to work properly.
  2. Launched, flew about 1/3rd of flight and telemetry stopped by images kept appearing.
  3. P3 finished flight plan, returned to home. Camera did not return to level. Landed, shut down, but mission did not complete. Eventually powered off.
  4. It appears that the camera was triggered far more often than expected. The turns have a lot of images associated with them.

Flight #3

  1. Planned, launched.
  2. Just after takeoff, Flight #2 “completed”. Dialog boxes appeared over current flight display and I was unable to return to the current flight display at any time.
  3. Flight completed normally, including the normal “flight completed” notice.

The flights are all in my dash board.