_ ios 14...How is it going?

Reports are starting to come in that ios 14 is not contributing to as many problems that the introduction of ios 13 did.

If you’re using ios 14, let the community know your experience, good, bad or otherwise.

1 Like

I know the beta had 3 key issues that could easily affect us specifically. WiFi connectivity problems, general lag and a location based service issue with some 3rd party apps. The last one is similar to what happened with Android System Webview a while back. They never stated anything after beta so I assume all these were either fixed or minimized to “acceptable” levels. From the release notes it is primarily an interface and multi-tasking upgrade, but we shall see.

Hey team,

Thank you for reporting the issues you’re facing with iOS14. If you have any screengrabs or specific behavior to report, kindly send an email to support@drondeploy.com.

In the meantime, the Support Team will monitor for further reports.


1 Like

So anybody having issues with DD (latest ver.) and iOS 14? My iPad wants to, but…

I ran a standard map yesterday without any issues, but I have a big day tomorrow and will report back.

1 Like

I just completed two multi-battery 600 image missions with no issues. One of them was a linear roadway. I did not use video or any other non-map missions.


Hi there! Are you receiving any type of error message or pop up when accessing DroneDeploy?
You may consider letting the DroneDeploy app access the “Local Network” from your iPhone’s general settings.

If you are still having issues, please send us an email at support@dronedeploy.com.
Thank you!

I had a few issues yesterday that did not happen today.

  • New mission planning continues to default to Mavic 2 Pro and DJI camera control. This is a pain and hazard when planning a flight for a different drone. It causes the flight plan to be manually manipulated to fit the specs of the used drone when connected.
  • I had to reboot the app because of a blue screen hang and when I returned to the mission I had just finalized all the settings had been returned to defaults including Enhanced 3D.
  • The blackout of the map after a battery swap on a multi-battery flight still exists.
  • On commencement of takeoff on a separate flight the FPV was blacked out and did not return even after switching to map and back. Once the mission was complete I switched to Litchi so that I could see what I was going to shoot it worked perfectly. Without rebooting.

Clarification. Once again my iPad did not automatically or notify me of an update. This must be something with the app as all other apps on my devices at least trigger a notification. Even right now when I searched for it in the app store it said open, but when I clicked on the name it said update. @Jamespipe

We roll out updates gradually - Apple has a feature that enables us to roll auto update to 1% -> 10%> 100%. If you are still in the 99% -> 90% bucket you have the opportunity to manually update.

1 Like

I updated to ios ipad 14 and DD will not run at all for me. I can open it without the bird connected, but if it is connected, it is game over. I have an ipad Pro that I always use. So I stumbled thru the day with my backup android tablet which was also very rough. Then P4P dropped out of the sky so not a good day.

Hi all,

We’ve just released a new iOS version, 4.18, which addresses issues some of you may have had with iOS 14. This is available now on the App Store.

Happy flying,

I ran 4.18 today and it worked well. Enhanced 3D with nadir and perimeter and a ton of manual obliques.

I updated ios to 14.0.1 (patch update) and now have DD on 4.18. This morning all seems ready to fly so I will be heading out to fly in a couple of hours. I am optimistic all will be good to go. And for clarification my P4P dropping had nothing to do with DD. It just added to the less than stellar work day.


No real issues while flying with DD 4.18 over the past couple of days, EXCEPT, the drone fails to continue a mapping where it left off during battery swaps. It goes back to the starting waypoint of the leg, just like the old days. What happened to that functionality?

IPad Mini 5, latest iOS, P4P v.2

1 Like