First testing iOS Beta

Hi there,

I`m an drone operator from Holland and first of all I wanted to thank DroneDeploy for letting me test the new iOS beta version of DroneDeploy.

I have tested the software last weekend and the first impressions were very good. Currently I`m uploading the images I got from the previous mission. So I need to wait for the results.

However I did encounter some issues whilst performing the flight. I have read previous topics where some issues where discussed but I wanted to mention this anyway.

First I noticed that the flightspeed was pretty high (approx 32/33 mph) which resulted in a very short battery time. Maybe there should be a function where you can put in a lower value for more battery time. I also found that because the aircraft wants to accelerate as quickly as possible to the flight speed set by the software which might be an issue for the battery. Because it is asking so much power it might result in a crash due to battery failure.

Second issue was when the aircraft landed the camera keeps taking pictures. Even when I closed the app and started the DJI GO app. Not that its a big issue but you need to filter the wrong images.

Third issue is when I wanted to continue the mission (mission was to large for 1 battery) the aircraft would not take off when the pre-flight checks where done by the DroneDeploy app.

Also when I wanted to plan the mission on the desktop I noticed that the flight direction could not be altered. It would be nice I think if this feature was enabled :blush: .

I still need to do some more testing but the weather is very bad here currently. If I have more results/details from testing I will let you know. Before I forget to mention this I am using A Inspire 1 with X3 camera and iPad Air 1 (with latest firmware updates and software)

Greetings from Holland.

Lammert de Graaf


I have uploaded the photos and try to see where all the photo`s were taken by clicking on the projections button within the map engine. Here is a screenshot of what I saw:

I don’t know if this is good or bad and the map engine is still processing, but I don’t think that all the pictures have a overlap.

Do you remember the altitude that you flew this mission at?

Something seems weird with this map. I’m referring it to our support team. There is also the small possibility that the camera triggering didn’t get set properly due to a bug we fixed this past week.

I can’t see the logs for your flight where continuing the mission failed. Usually we can see some sort of error from the drone that prevents it from taking off.

For the map, it seems the projections are calculated incorrectly, but the map stitched fine. The second half of the map is missing because it doesn’t have the images, since you were unable to continue the flight.

Yes the altitude was 80m AGL

That’s right, the other half could not be flown because the aircraft did not take off when I pushed the green button when the flight checks where done.

Maybe I could get the flight logs from the aircraft itself? would that help?

I only tried to plan a mission, i didn’t fly it yet.
But now my cam view has gone and the Go-pilot app crashes.
i already reloaded the GoPilot app but no cam view and sometimes ‘no connection’ when i hit the ‘camera button’
A very detailed sequence on how starting up and shut down is needed.

The DroneDeploy app doesn’t adjust any camera settings until you actually takeoff. I am thinking the disconnection issues are DJI related. If you provide more details maybe we can help figure out what is wrong.

Well i went out watched the fireworks…'15->'16
Came in and retried and now it works again…
Allthough on first opening of GoP app it quits after 2 sec. and on second launch it stays open.
Now i had to go throug initial GoP app steps.

Fingers crossed i hope to fly-try at noon !-)

Details:GoP app 2.4.3 AC RC 1.5.70 Cam
DD 1.44

thnx 4 quick reply

did a first test flight but needed to abort in flite.
After takeoff AC headed wrong direction after direction yaw it went to another point were it turned to fly behind me…then a aborted and returned manualy,

Interface is complety white with only Batt/duration/alt/speed indic and a green and blue button
By Accident i found out i needeto double click on the green…
no map background and/or cam view…
Later on one needs to restart AC to see if something is saved in app…
i need some help… even to try and get this answer mailed…

hi @dxtrty

I’ve never heard of it traveling in the wrong direction before. This is also the first time I’ve heard of the interface being completely white. Have you tried using the app while at home using the simulator first to see how it normally works.
You should only need to click once on the green button in order to take off.
There is no need to restart the aircraft to see if something is saved in the app.

I found the trail map , it is in the ‘simulator’ [not obvious]
when i tried test flite , it did go to the first point . but i the planned trajectory seemed to have shifted to one side.i made a mistake when i saved? i think
Probably due to the lag when i try to draw it in the planning.
now i try to make a new plan but the map always start in SF USA and after i drag to Belgium it jumps back to USA…
is there a manual/tutorial how to plan-start up With iOS-inspire1.

There shouldn’t be any difference in the simulator and a real flight aside from actually flying a real drone.

In order to make a plan, you need to have a drone connected and turned on. It will then use the drone’s current location.

I did turn on my drone and when i swipe to my location i see the blue dot, but when i tap on the screen it shfts back to the USA.
I will try again in another location where i have better Sat coverage, now i only have 4-5.
thank you for your patience