DroneDeploy iOS Version 4.2 Bugs


Now that their has been an update I am moving to a new thread. My experience this morning, not good. probably the most notorius construction project in Austin right now and my DA tried to fly it with the new 4.2 version of the DroneDeploy App.

  • 32ac Foootball Stadium, yes - not American football, for our new Club FC Austin.
  • Multi-battery crosshatch with a 65-degree gimbal pitch.
  • App took longer than it should to boot to a fully populated interface. It worked well going back to the old view.
  • Lag started about 5 minutes into the mission and had several green flickers. I use a parabolic antenna and have never had any issues with video until the new UI was released.
  • By the time the first battery was coming to an end (2/3rds if the way through the entire mission) the drone on the screen was two passes behind actual position.
  • The live PiP continued to work so I was assured it was still taking pictures. What dos not work with PiP was when I tried to expand to fullscreen. The same behaviour as the video I posted on the old thread.
  • The scary part was that because it froze the battery continued to report its percentage at the point at which it froze.
  • RTH notification started which is usually at 25% and the UI still reported 41%.
  • The screen became completely unresponsive so I manually flew it back and switch batteries while rebooting DroneDeploy.
  • I was prompted to continue the mission after getting DroneDeploy back up (which is good), but the precision point return did not work and it reran the last leg that it completed on the first battery.
  • The remainder of the mission completed successfully. Thank God I am very comfortable with the situations and hacking DroneDeploy because I could have very easily looked like an idiot to investors on a $240 million project!

I updated the app yesterday and my issues were almost identical to yours Michael. Today just happens to be my subscription renewal day so I am not sure what is going to happen next. I am not going to renew just to keep experimenting and see if a fix is released but I will have no way of continued testing without access to the platform. I may be shopping for a new solution.


Update…I tried another test flight using another device, Iphone X. All other apps closed, wifi and bluetooth turned off. I was in an open area with nothing to cause interference. App load up and pre-flight checklist when fine and I hit the fly mission button. Less than 100 feet after taking off it lost connection and flashed an error message on the app saying it was trying to reestablish connection. Meanwhile the drone continued its flight plan. I let it fly for about 10 minutes still with no reestablished connection before I pushed the RTH button on the controller (it would not respond through the app RTH). The drone safely returned but the app still refused to reconnect until I shut the app down and restarted. This doesn’t give me much hope that an updated tablet would solve this issue.


I agree, it is almost getting to the point that I will not risk our corporate assets if this continues. Much less expect another pilot to go through this. I have plenty of apps to fly with and could just continue processing and collaborating with DroneDeploy.

Today’s experience. The new UI is NOT good. I can’t emphasize enough how many of these problems are directly related to it. The population of the UI assets and the ability to search would not work at all so I switched back to the old view and it worked fine. Problem is that even going through the old UI you get to fly with that new UI. While it never completely froze PiP did blackout constantly. Lag in the live progression persists, but the longest lag was only 3-4 seconds and it never completely froze or had to be restarted.

1 Like

@MichaelL In the new release we’ve also gotten better at monitoring performance and finding these lag spots you’re seeing, so expect more performance improvements to come soon! We still recommend using your most current device for best possible performance.

Important to note that we do hundreds of real test flights on new app versions. They are safe to use even if you encounter a bit of lag.

Does what we are experiencing sound safe to you? Loosing connection to the drone and having to force-quit an app is anything but. Being unable to read live telemetry including the battery level is definitely not. I understand the role you play and the answers that you get, but tread lightly as safety is (should be) the number one goal of everyone on this forum. I also understand that you say you perform hundreds of flights, but how many different drones and how many different devices in different configurations? I do hundreds of flights just in DroneDeploy personally in about 6-months.

1 Like

@MichaelL Safety is first priority - we test on every supported DJI drone and iOS device - there’s an army of them in the office :slightly_smiling_face:

Nothing in our app affects connection strength with the drone - if you are losing connection you are out of range with the transmitter, regardless of which app you use.

Constructive feedback is always appreciated and the team is working hard to resolve your issue. I’ll loop back with news after further improvements.


Except for the fact that I fly with a parabolic antenna and NEVER lost signal until the new UI’s. That includes Pix4D, SiteScan, Litchi and UgCS. Pretty impossible that I was out of range today when it was 225ft above me.

1 Like

This “out of the laboratory” answer is quite sad in relation to the practical expertise of MichaelL who gives us field users here in the forum the impression of DroneDeploy being a caring and trusted mapping company.
Listening to customers is always a good idea; blaming them for causing the malfunctioning of the own product is just short sighted.
The reason seems to be obvious: changing a running system caused it to break leading to embarrassing situations for the user and even impacted operational safety.
I know, that you at DroneDeploy really take a lot of effort in fixing stability issues running a “conglomerate of unstable systems”. A very difficult job. And I noticed many times that you really get issues fixed!
Please give us and yourself the favour to not start reacting like being never-failing.


Perhaps you could elaborate on DD’s flight app alpha and beta testing protocol, @Andrew_Fraser ?

Perhaps you could have the actual folks that went out and flew the new version on missions of 20 to 50 acre sites where the app performed splendidly come on here and show us what others are doing incorrectly?


Screen recording from brand new 10.2 iPad…

New UI Experience 01-22-2020


  • Slow loading thumbnails. Imagine without WiFi.
  • Top bar text is odd formatting and changes.
  • While the Search bar let me enter text quicker than it normally does, it does not commence searching.
  • I was not able to click the found result so I attempted to scroll down to find the thumbnail.
  • Still, none of the thumbnails have populated and I couldn’t click on them.
  • Thumbnails populated 45 seconds into the journey.
  • Explore view would not populate. It populated 15 seconds after I stopped the recording.

That being the case, can I ask again that you allow us the stable version until things get sorted? Your previous statements led us to believe that things were on the up, where in actual fact they are quite the opposite. Things have gotten worse.

If @MichaelL isn’t able to trust your current version of the app, someone you’ve featured in the past and marketed your product using his extensive background, then I struggle to understand how someone like me, with far less experience than him is able to.

Please revert to the old version or at least allow us the choice. As with a few others I suspect, I can’t see me renewing my subscription otherwise.


Is there any news @Andrew_Fraser?

We have found the source of what is slowing down app performance for those on this thread and apologize for the issues it has caused. Resolving this is top priority for our mobile app team and we will be submitting a new app version with this addressed as soon as possible. We appreciate your patience.


You guys are awesome! Those of us who have beta-tested software know that some of these things can be quite tricky. Especially when users can have different software versions and we in the forum happened to be the minority that are on top of things. I appreciate the efforts and communication.

1 Like

Yes. What he said. Thank you. Fingers crossed this works now. It’s been a long time coming.

1 Like

@Andrew_Fraser. Do you anticipate the fix to take a few days or a few weeks? Now that you’ve identified the problem, is it an easy fix or one huge headache?

1 Like

Thank you and the DD team for your true diligence to this issue. I’ve had most of the problems that people have been describing here. I had to cancel a recent mission because I am leery of flying in cold temps and having the app not telling me of the battery level or how far along the mission was for the large number of acres I needed to fly.

I appreciate your efforts and look forward to flying again with DD.


I have found another issue with the latest update when using a 3rd party camera on the Inspire 1 and 2. The app reports "Drone Connected, but no GPS lock. Move drone or wait for GPS Lock” message and Drone Deploy will not allow an automated flight routine to take place. The DJI apps all show 11+ satellites, but DroneDeploy indicates 0 satellites although the signal bars show good GPS signal.