Invalid corner radius

I have been exploring the dronedeploy functions and are very impressed.
However, sometimes I encounter a error message telling me that the corner radius are invalid.
What is the cause and how could I avoid receiving this invalid radius message?
Best
Karl

@Stockholm This is a known bug and we are working with DJI to fix it. This is most likely caused when the flight plan legs have a big acute angle. I’d suggest meanwhile to avoid this by rotating the flight plan.

This issue is killing me. The app would be great if it didn’t hit this glitch every* time I try to launch a perfectly planned mission. Doesn’t matter how I change the angles, still happens to anything beside a perfect square. Any fixes / ideas??

This shouldn’t really be happening because we have code to prevent it. Are the plans that are failing for you still on your account? I can go load those onto a drone and see if we are able to reproduce it.

Yes it’s any of the whiskey island plans. Please test and let me know if you have the same issue. I hope it’s not my drone because I don’t have another inspire 1 to use. All the firmware is good and there are no errors that show in DJI go app.

I have the same issue. I’ve updated my iphone to the latest version 2.0.36 and I keep getting the same message under waypoints “corner radius invalid” I’ve tried changing angles, altitude, size, everything I can think of and nothing helps.

I’ve also tried creating a brand new flight plan and still get the same issue.

What do I need to do? This is very frustrating with the 99.00 per month I’m paying.

Carl

@cnaone2274 which plan in your account is having this issue (you can share the link)? Is it on iOS or Android?

https://www.dronedeploy.com/app2/planning/58cd8f84b671a3349784dffd

https://www.dronedeploy.com/app2/planning/58c58094a787ccbce08e3011

This one is from one I copied. I ran the simulator to see if it would work and it did. However, not shows it with the UPLOAD Icon. How do I reset it so I can attempt to fly the mission?

https://www.dronedeploy.com/app2/mapengine/58d984c35c19ed08465c474d

This is using IOS

@cnaone2274 unfortunately you can’t reset to edit, buy you can get around this by making a copy of the plan.

Hi Chase,

I received the Invalid Corner Radius error today, 14 Nov 2019, and need help understanding the steps I should take.

The map plan in my account is names Bay Water Tower - Big.

Thank you in advance.

1 Like

Personally I have never even heard of this until I saw your post and back-read the thread. Pretty strange as the last post was more than 2 years ago.

Is it giving you this error while your are flight planning?

Does it matter if it is on a mobile device or a computer browser?

Please list your,

  • Internet browser make and version
  • Mobile device make and model
  • Mobile operating system and version
  • Drone make and model

It does give me this error when the program is running the flight planning checklist. Additionally, I’m running DD using a Phantom 4 Pro, with an iPad. I tried initiating the flight checklist multiple times and adjusted the map on the screen thinking that would help but it didn’t. Finally, I logged out of the program, restarted everything (again multiple times) but wasn’t able to complete the flight.

I came home and look at the flight plan (it’s just a square) and I’m not seeing anything that would have caused the error. I tried running the simulator to see if I received the same error but I didn’t receive the error message and the flight plan loaded as expected.

1 Like

What iPad, iOS and version of DroneDeploy app?

iPad (5th generation) Model: MP2F2LL/A
iPadOS: 13.2.2
DroneDeploy App: Version mobile - 3.18.1 (includes latest update from 3 Nov 2019)

2 Likes

This is really strange as there have only been 4 reports in 3 years and the threads just dropped. Please email support and be ready to provide logs and the info I asked for. Sorry, no ideas here.

Hi Michael and Chase,
I ran the simulator on three different Apple devices (iPhone 7+, iPad 5th gen, and Macbook Air). You’ll notice the ‘turns’ on the iPhone and iPad are angled, but on the MacBook Air the turns are nice and crisp as they should be.

Just wanted to share this extra bit of information.

2 Likes

Thanks for this. It should be very helpful. Chase is no longer on the forum and I do not believe he works for DroneDeploy anymore. @Erika_Houseman may be able to assist from here. Just from my experience the rounded turns look more realistic particularly with the new rotational-drift method of turning which is another reason why I am surprised that this is coming up.

Same error here on the second leg of my flight plan… all I did was changing the battery… any ideas on how to fix it?! i’m using ipad 4 mini and mavic 2 pro

1 Like

exact same issue on my end.

iphone 11, mavic 2 pro

1 Like

How are you all creating your missions?

  • Mobile device
  • Web Interface
  • Web Interface with KML Upload