Inspire 1 Firmware - Older Beta / controller 1.3.00

Tried to fly using latest DD beta app for the first time in many months today.Everything went well, up until getting stuck on the “Starting Mission” screen. The Inspire never took off. I tried smaller missions and this did not work either.

I have not updated from the Beta ship firmware from last summer. This firmware has been rock solid for me the whole time, and I don’t want to lose functionality with other 3rd party apps such as Litchi. Any options or opinions?

That’s a pretty old firmware. We try to maintain support for the last two firmwares if possible, but sometimes all the changes make it difficult. I believe litchi should still work with the newer firmware. Do they claim to not work with he latest?

Thanks Chase. I’ve been doing more research and looks like it will work with the newer firmware versions now. I’ve just been a bit behind on things and getting caught up.

A lot of users report 1.4 was the last “good” firmware version… Will DD still work with that?