Freezes on first waypoint

Detected on Inspire 1 (Latest firmware). It freezes on WP1 and doesn’t proceed a mission. We have to call it back and start the mission again.
DroneDeploy 2.0.19
iPad mini 4 iOS 10.2

1 Like

Hi Vadim,

There are some issues with Inspire 1 that the team is working through. Are you using an X5 camera?

What are the issues and are they affecting everybody? I have had no issues with my Inspire 1’s but I am using the original X3 camera.

That’s good to know, I’ve been seeing issues with X5 and have made the team aware of it. Glad to hear your original X3 is working well.

I’m flying an Inspire 1 V2.0 with standard X3 and I’ve had many, many DD app crashes upon reaching the first waypoint. I have no idea what I’m doing wrong. It just seems to take many tries and resetting and rebooting the aircraft and restarting the app for the damn thing to just fly it’s programmed route…
Android 6 on a Galaxy Tab S with latest firmware.

1 Like

Same problem here. Original inspire 1 with an x3 cam. Pauses on first or second waypoint and if it does proceed along the entire mission, it takes pictures erratically leaving large portions of the map uncollected. I’m also unable to look at flight logs because they aren’t being recorded. Using iPad Air 2.

I traveled 45 minutes to a job site yesterday to complete 300 acres of ag mapping and had to turnaround and go back home because the app wasn’t functioning properly. :rage:

I also tried running the mavic pro and we have issues with the camera not focusing correctly. We set exposure in DJI go 4 then continued in DD.

We need this resolved quickly because we are in the middle of mapping season and are unable to deliver anything to our customers.

1 Like

Is somebody from DD watching this?

1 Like

I am having similar issues with the app crashing at the first waypoint. Using a DJI inspire 1 with X3 camera and Galaxy Tab S.
All software is up-to-date. This is severely delaying my projects.

Sorry to hear you’re having this issue.
We aren’t able to see any reasons why this is happening for you. Is it possible you can send me a private message with a private video link or something? This would help a lot with us resolving it for you since we can’t find any crash info in our logs relating to your flights.

You can’t see any crash info in the logs because the 2 flights I did were successful. It just took like 6 or 7 attempts and lots of restarting and resetting before my Inspire 1 flew the planned route. For every unsuccessful attempt, all pre-flight checks are okay and the app then says I’m good to go, so I hit start… the drone takes off nicely, flies at the correct altitude to the first waypoint… and then the app crashes and the drone just hangs there of course, not knowing what to do. After many tries, it just works all off a sudden… it’s very strange.

I am also having the issue of freezing on the first waypoint. My Inspire 1 (v2.0) with X3 camera will fly to my given altitude and go to the first waypoint. From there, the app still is communicating with the drone (as I have used it to call the drone back), but it will just begin drifting away (generally with the wind).
I have the latest software and firmware, I have strong GPS and controller signal, and am not near any no-fly zones or large sources of interference.
I would like to do some drone surveys for a science project and any help on this problem would be greatly appreciated!


This usually means that it is having trouble taking photos. We have made some improvements to try to help the camera get into a good state before takeoff. These should be coming in the next week. In the meantime make sure you take an image in dji go before the flight and also resetting camera settings in DJI can be helpful.


Thanks for that input. I will go into the DJI Go app and see what I can find. Do you know if there is a certain setting that works best with DD? I’m not sure what the defaults were.

I will try taking a picture before my next flight in DJI Go and then try to map an area.


I reset the defaults on the DJI Go app, opened up DD, and flew a mapping mission over the school’s bus loop. The drone unsteadily went to waypoint one, and then pointed toward waypoint two, and proceed to drunkenly wander in waypoint two’s general direction. I attached a screenshot of the flight before I turned around to land.

Any other suggestions?

Could you try recalibrating the IMU and compass as well?

Okay, I will try to do that once the rain lets up! Thanks!

I was able to get back out there and here is the result!

I am super stoked that it worked. Does DD automatically choose exposure levels for the pictures? The pictures used seem a little overexposed.

Hi @stithjim,

You can set the auto camera settings in the DroneDeploy app. If you take a test picture and feel like the pictures are overexposed or underexposed, you are able to turn off the auto camera settings in DroneDeploy and adjust the camera settings in the DJI app. This way you can adjust your pictures accordingly to your preference.

aerovisionsolutions, have you gotten any DD followup on this yet? We are mapping 1700acres in Seattle and running into the exact same problem you are having. Our frustrations is DD software isn’t reliable enough to warrant the fees. The fees seem unwaranted, when we are truely the beta testers for a “beta” quality product. At what point, when you pay several hundred a month for service, does the service provider take fiscal responsibility for their part in our business loss or resources being used multiple times just to get a single job done.

If you’re doing this for money - you’re about to take a big hit if you stay with DD. The DD product is collapsing. Look at the amount of people in the forums complaining about software and how those voices have significantly grown in number over the past year…Goto the Pix4D forum, for example, and see how many people are complaining.

#1 Priority for any product is reliability - it just needs to work regardless of this and that situation. Particularly because I’m using it for a business and clients will walk to my competition, quickly, if I don’t provide. They don’t take excuses. It either gets done or it doesn’t. And if it doesn’t - you don’t get called back. Period.

I love DD interface, the processing engine is really really good. Best around IMO. I’m hoping they circle the wagons soon, re-assess and get their issues worked out. They would likely mean some changes at their Executive levels too if it’s gonna work IMO.