Inspire 1 Keeps Stopping Flight During Grid Mission

I have been flying the inspire 1 with DD app for the past 6 weeks and the drone only successfully makes it through the whole mission once out of every 6 or 7 attempts. It will typically make it through the first pass and usually before the third pass it will stop in mid-air, the camera will come up to face forward, and the inspire will just sit there until i tell it to come home. This has happened on about 25 out of maybe 40 missions now. We have tried leaving it up there hoping it will resume the mission but never does (assuming a lost GPS signal or something but usually have 15+ satellites).

We have checked firmware compatibility with all devices and have the DJI GO app settings correct and the app shut down as suggested. Has anyone else had this issue lately?

Aircraft and camera: Inspire 1 v1.8.1.00
Controller: 1.6.0
iPad mini: iOS 8
DD app: 2.0.8 (iOS)

1 Like

Do you see this same behavior if you run waypoint missions in DJI go?

I have actually not tried that, although before i was using Pix4D grid missions without any problems. Ill have a go at it and see what happens (a DJI GO if you will).

After reading a few more forums i tried replacing the USB cable from the controller to the ipad and it seemed to work without that issue for the last 8 missions i have tried. So for the time being it seems we found the culprit, but i will update if that changes!