Dd wont load waypoints on new update please help

Sorry for the captitals just relised…
I have a p4. Now on a job today i have driven 350km to do, the waypoints wont load. How long should they take.
The battery level got to 70% and still no tick.
Im still on a trial plan but based on this its embarrassing and is costing me. So weather i pay for this is getting pretty much canceled.
Can anyone help with ideas. Has worked fine previously before the damn update

Did you restart the drone and the controller? Are you on android or iOS?

Im on android up till yesterday everything woked ok flew a couple of flights last sunday before the update no problem.
I have done the following

Swapped cables
Used a android phone only loaded with dd and swapped in after the dji setup
Replotted the flights… had due to hardly any service
Restarted everything numerous times.
When un plugging cable galaxy tab restarts? ??

How long should the waypoints take to load on a 75ha grid
75x75x75 settings

Need some help as im guessing this is due to app changes

I don’t think anything should have changed with how waypoints are loaded. We are using the latest SDK from
DJI now, so it’s hard to say if something has changed there. We have flown many times on several android devices and drones using the new SDK.
I’m trying to think what could cause it to sit there. It should load pretty quickly like it used to before the update.
Is the controller in the right mode? It should be checking that, but just making sure.


I have the same experience with a P4 and Android (Tab S3 Lite). It will inconsistently load the waypoints and then just not do it. I have tested with smal and large areas and it is more likely to fail on large ones - today i tried to fly 260ha. Eventually it worked for the first two batteries and then failed again on the third. So I spent 6 hurs and only mn=anaged to fly less than 100ha.

I checked the forums and found the beta version that was said to fix the issue. Installed but still got the same issue.

Which beta version are you referring to? There shouldn’t be any beta versions available for download.

A fix for the waypoint issue you’re seeing is in our release coming up. Sorry you’ve been having trouble.