Waypoint distance error

I had a similar error when the system went through the checklist prior to flying. Mine came up with a Waypoint error as well. “Checking Waypoint Status” … “Execution of this process has time out… return to planning.”.

Couldnt get it to preflight without closing the program and restarting it. That was my last flight and havent started a next field since.

Also on this field the GPS coordinates didnt show up on my photo info when reviewing pics. Just showed the name of the municipality. Seems to have processed so the geo tags were there just no coordinates were displayed. Field was setup on desktop prior to arriving at flight location.

The map wouldnt load up the first time till i turned my wifi hotspot on for the app. I thought this was supposed to run without wifi if we first set it up and run it wifi connected at home. Any tips?

@Guanrixing @craiglenz We are investigating this issue with DJI. It looks like there is something up with latest firmware but not fully sure yet. Hopefully we will have a fix soon. Meanwhile, please try restarting the app.

I am getting the same error message. Is there any news on this fix? Thanks.

Not yet,Error still exists!

Apologies for this- we are working to get this corrected.

Me also having the same problem.

Any update on this problem yet, or circumvention?


In addition to your Waypoint message, I also get the following:

Although it says “Aircraft is taking off”, it does not leave the ground.

Is the drone not taking off when it says that? What is the state of the drone?

Are you starting the motors or anything while it is on the ground?

The drone is a P4 in near new condition.
I run the dji go app first to ensure it has gps and ready. I turn it off.
Then i start the DD app and start motors.

Try not starting the motors and let me know if it helps

Hi Chase
Yes, not starting the motors allowed DD to take control and flight the mission.
Hopefully, DD can change the message to direct the pilot as to what needs to be done to continue.