Says flight plan is available offline but no way points green check when I press fly?

It did it again today! Have about 5 plans saved & was only able to fly one mission! To top it off the FPV screen did NOT come on the entire flight. So not good! All the other flights had a flashing circle on the way points with all other green lights checked.Mind you all flights said available offline too??? I have the latest version, restarted bird, RC, & tablet many times to no avail!

Please advise?

Hi Kemani

I’m super sorry to hear of your experience. Super frustrating.

What drone are you on?

FPV not showing up is always a bad sign for the state of the drone. Sometimes going into DJI GO and taking a picture can help reset the state, but the fact you turned your drone on and off should have resolved.

Offline should just refer to the map tiles being available - did that work? If so it sounds like there is an issue sending the waypoints.


Thanks for responding Mike! At this point I’m stumped as to how & why ALL these issues keep happening repeatedly. The DD TEAM has OBVIOUSLY spent a lot of time, money, & etc. to deliver such a brilliant platform that truly is TOP NOTCH in theory & could be the best software for a drone EVER…besides the RTH technology of course (#1 BY FAR)!!!

Were you guys able to pull up any of my saved flights to troubleshoot?

Just curious… Once the plan is saved & downloaded for offline use why is there a need to do anything but connect & fly? IDK seems a bit redundant to me?

Just saying… this can be an “Oscar Award Winning App!!!”
Hope to hear from someone soon.

Kemani Bandy, Sr.
FAA Certified Remote Pilot

Ps Can I give you my cell or have a number to call & discuss live?

P4Pro, Samsung Galaxy Tab A (10.1")

@Kemani_Bandy Happy to speak with you on phone. Are you using our latest version of app v2.0.44?

Yes I have the latest version of the app. Would you like for me to call you or can I leave my number for you only?

Thanks for saying that. Please share your number with Manu, you can click his name to send him a direct message with your number.

OK Thanks Mike for responding!

Sent Manu my info but no call back yet. Went to fly and still having a lot of the same issues. Most plans won’t fly (checking way waypoints uploading status), live cam feed box is completely gone, test mission I did in the field worked but when it arrived to the location bird just sat there at the starting waypoint. Said it captured 1 photo, but with no way to view cam and the bird seemingly unresponsive I just hit the go home button???

I haven’t been able to fly a mission successfully in 2 weeks now! I’m at the point where I’m ready to be done with DD!!

Hi @HawkEye_Imaging,

What issue are you experiencing?

Camera facing forward, not taking pics, setting at the first waypoint while app shows its flying course, the problems lately are numerous

I agree that there are seemingly numerous bugs with this latest version…

Here’s the problems I’m having:

No live cam feed window during flight.
Flight plan gets all green checks, except Way Points check.
Dashboard says available offline line but also says
Information not uploaded yet.
Drone not connecting on screen even after resetting Tab, Bird, and RC.
Got a flight to initiate once but flew from home point to starting way points and just sat there. Tried to see if Bird would complete mission but with no live feed options RTH.
Please Help. It seems that people want to use the app, but it is becoming way too fustrating!!!

I’ve uninstalled & installed at least 8 to 10 times in the past 3 days!!!

Hi @Kemani_Bandy Sorry for delayed response - I left you a voicemail. Hoping to connect with you later today.