Beta 1.2.3 Bugs and Feedback

Thanks for trying DroneDeploy for Inspire/P3 1.2.3

Please add feedback and bug reports as a reply to this topic.


Yesterday, I tried to fly some missions:
P3 Pro
Firmware beta 1.5.0011
DroneDeploy 1.2.3
Google Nexus 5 - Android 5.1.1

First of them was none tat I had flown the previous day. All the checks wera Ok, the bird took off, camera pitch down, hover for some seconds at 1-1.5 m , some beeps and landed automatically.

Tried for some times more and all the same.

After restarting phone, remote and Phantom, tried to start a new mission (the default one), only pressed red button for starting checks, all were fine, and when pressed green button for starting mission it takes off, camera pitch down, hover for some seconds at 1-1.5 m , some beeps and landed automatically

What can be the problem? Previous day I had found that this behavior can occur:

  • When the Phantom “thinks” that the battery charge will not be enough for the planned mission.
  • When the takeoff point is very far from the mission area (I tested with >450m)

but been able to finish a mission with a fully charged battery and taking off near the flown area.

That sounds just like the issues I had after running an RTH procedure on the previous mission. It seems that the app cache on the tablet (or phone in your case) was keeping the RTH request and resubmitting it each take off. Does that seem like what you have? If so, my solution was to reset just the tablet / phone, although if that isn’t working for you I’d try clearing the app cache. Can you try a mission with DJI GO just to confirm everything is OK and confirm it is the phone that is the issue and not the A/C or RC unit?

After not being able to start any mission with DroneDeply, as I had travelled for flying I did some:


  • Free flying
  • Several POIs (orbit)
  • Follow me


  • Seveal POIs (orbit)
  • Ground staton mission

All of them were Ok, so I suspect there’s something related to DD
I’ve not deleted the unfinished flights on DD’s dashboard so they can see a fix for this.

Generally OK but a bit hit and miss on the regulars…

Out of about 30 flights / mission plans to the point of launch…
I had 1 app crash on loading app.
I had one camera error which rectified on second attempt, so it doesn’t really count.
I had 2 RTH alarms on Take Off with immediate landing. (Like Antonio had, above) In both cases just restarting the app cleared this. (Nexus 9, Android 5.1.1, DJI 1.5.0011, DD 1.2.3)
Waypoint issues - Standard Overlap I could run to somewhere around 35 waypoints +/- 4 (it varied)
High Overlap - if I could get above 25 I was doing well. Never got above 28 to work.
It didn’t seem to be mission length as I set up a mission with 1km legs but 10 waypoints and that seemed to load up fine.
I was trying things at 70’ and 150’ and it didn’t seem to make much difference to how many waypoints I could load.
Continue Mission worked fine on Standard but on High Overlap it doesn’t work at all.
I was a bit short on time, so most tests were just launch/recoveries and I only let a couple fly past the first few waypoints. None were complete missions.

Firmware beta 1.5.0011
DroneDeploy 1.2.3
Samsung Galaxy Tab s- Android 5.0.2

without the 2 last Points
then Popup:
failed to test Photo
improve the rc Signal

shut DD return to DJI go
…its black red at the middle top no connection no Camera

turnd of all
DJI go is now o.k.
DD… the self problem

have i forgot anything???
iám hearing the klicks (photo) on the inspire camera , but it is not a testphoto on the card

Had a strange issue where the platform was stopping abruptly for every picture and then abruptly accelerating back to speed, making it sway back and forth on each shot. The strangest bit is it did this for a while, then stopped mid-flight, then did it again and stopped. Images all look clear enough.

Also had the camera initialization issue again, but this time I was unable to clear it, even after resetting everything and trying for about half an hour. In the end I resorted to Plan B to get the mission flown. Interestingly, the camera initialization issue carried forward into the other app on the first mission, but cleared on second attempt.

DJI Phantom 3 Professional
DD - 1.2.3
DJI Firmware - 1.5.0011
Google Nexus 7 - Android 5.1.1

Wanted to pass along today, I had six successful flight with my largest being 90 Acres. The only issue that came up is upon landing the aircraft will not shut down. I have to manually kill the motors with left down on RC Controller.

Everything else is working great.




DJI Phantom 3 Professional
DD - 1.2.3
DJI Firmware - 1.5.0011
Google Nexus 7 - Android 5.1.1

Today had a new issue creep up and it’s dealing with camera check. It went thru all the steps then said that it could take test picture. It happen numerous time, so I went and tested the camera out with DJI Go without any issues. I snapped a few pictures and then closed out GO app. Once I go back in DD app initiated plan and it worked this time. It appears that if their isn’t any pictures on the SD Card then it will not take a test photo.

I’m not sure, but that’s the only thing I can think of.




P3 Pro
DD 1.2.3
Latest dev firmware (from DD forum)
Nexus 7 2013 5.1.1

One OK flight.
Next flight kept getting camera errors - unable to take test photo (same issue as above).
Reinstalled app, flushed cache. Restarted tablet, controller and drone.
Free flew with DJI Go - all ok.

Finally worked out that I could fly another DD mission if I manually took a photo from DJI Go.
Everything worked fine after that. Did several runs in a few different locations. All good.

Side point - would be great if we could pinch out on the flight path progress screen after the mission has started. The maps provider embedded into the app has crap low altitude coverage here in NZ. If you start a mission zoomed into the level you need to be to actually plan a mission - then start the mission - you get no map underlay.
Not a major but sometimes it’s nice to see where you are in relation to the surrounding terrain if you’re trying to spot the aircraft by eye or just want to work out where you are.

  • 1 for the weird shutdown behaviour.
    Only had one full auto landing (I normally land manually to avoid deep grass etc).
    P3 landed fine, slowed all rotors then suddenly sped up and hopped around like it was still trying to land.
    Took over and landed it manually but noted the odd behaviour. Auto land in DJI GO seems normal.

DD 1.2.3 crashes immediately on my tablet while launching (Lenovo lifetab S8312 tablet with android 4.4.2) - no problem with 1.2.2

New Issue - Data Transfer Flight Logs and Picture Capture Count

@chasemgray @jono

DJI Phantom 3 Professional
DD - 1.2.3
DJI Firmware - 1.5.0011
Google Nexus 7 - Android 5.1.1

Over the past few flights i’m not getting any flight logs or Picture Capture Counts are not showing up. The app gives the transfer message and when you check the UI on DD Web noting is showing up. Besides this new issue and previous noted above all is working as expected.

Thanks again and keep up the good work.


We’ve upgraded to 1.3.0. Please leave feedback for that version in the new thread.