3/4 of way through mapping signal stops

Its been a long time coming but finally today I tried my first attempt at mapping using Droneeploy. It was a quarry, close to an airport, so sought correct permissions etc and all good. Mission flown at 263’. Initially I couldn’t get the mission to load to the Inspire 1 X5, but I turned it all off and on again and it worked. Off the drone went according to the plan, but half way through, the gps indication of where the drone was, was completely wrong. It looked like it had stalled. I was watching the drone and it had continued on its course as planned for a further 2-3 minutes. It then appeared to go off in a weird direction. 10 secs later the app stated contact with drone lost. I had to fly it back manually. The screen had frozen on the iPad and the battery life had frozen at 39% which is just not good enough when flying an inspire x5. Battery life is 15-18 minutes at best.
The only way to do any mapping with the x5 is to do small areas at time. I have to say after my first use of DD, I’m not sure its going to be reliable enough for me. If I can’t trust it to control the X5 properly and also not give live accurate feed back to the iPad then I either need to find the problem or not use DD again.

Thank you.

Sorry to hear it lost connection. It’s tough for us to have control over the connection but we do try to reconnection for several minutes after a disconnection has occurred. The DJI Go app is now using the same SDK that we have access to. If we lose connection they would have as well.