Continuous issues

Good Morning,

Ok, so I have now spent the best part of 3 weeks attempting to make a successful map, however I am continuously hitting a brick wall. Some attempts result in the drone flying the entire planned route, but only taking photos of the first half before the gimbal returns to its originating position and no longer takes photos. This happens no matter how long the planned map is. An example being, I had a 2 min 30 sec map set, the drone got 1-1min 20 secs in with 10 photos before the photos stopped, then I mapped a 4 min route, with the drone getting 2 mins and 32 photos in before the photos stopped. I have mapped the SD card, whipped it before starting the map etc. but no change. I am on the latest DJI GO and DD app versions also.

Other times I get one photo before the drone gives up, and others none at all.

The drone will always fly the planned route successfully, however the blue ´marker´ that moves from each waypoint to the next stops moving just before the photos stop.

I am quite disappointed that I am not yet able to make a successful map with a good number of photos, and I am really hopping there is a solution as I know the potential this app has, however I am on the verge of giving up…

Please could anybody provide some assistance and guidance as to how to resolve these issues I am having.

I am using the DJI P3 Standard with wireless connection to the DD app.

Thanks in advance

Quick question: have you tried uninstalling and reinstalling the app (both DroneDeploy and DJI)? I’ve found this helps.

^^^that, and make sure the DJIGo app is closed during DroneDeploy mission.

@karaemurphy @northarrow
Done both and still no improvement…

hmmmmm…what device are you using? Are all other apps closed? What UAV are you flying? Don’t give up yet!! I’m sure with more information, someone will chime in here.
At first I tried using my iPhone5—it was TERRIBLE! Didn’t work at all…I upgraded to a 6, and it was night and day. The UAV I’m flying (Matrice 100) takes two batteries, and the first time I took it out, the batteries were mismatched, and it too was TERRIBLE. Nothing worked for me the first few times.
That being said: hang in there and supply more info. How far away is the UAV when it stops taking pictures? Could it be breaking communication lock from surrounding interference? Are all the batteries fully charged? The SD card formatted in DJI Go?

I’m using an iPhone 6 and flying a P3 Standard. Every app bar the DD app is closed. I have swapped out batteries and no change, both fully charged, sd card formatted, no difference.

When photos are taken it usually gets half way through the mission before the pics stop and the gimbal returns it’s starting pisition. Sometimes the UAV will be at its furthest point, others it will be at its nearest point…

Then at worst the UAV won’t take one pic. The strange thing is the Drone will always fly the planned route without interruption so the signal appears to be continuous. I have also tried this in 4 different places now.

At a loss…

Silly question, are all the apps ip to date and the firmware on the drone?


Yep all updated prior to any mission and the firmware has also been done

Sorry to say it michja but its due to the drone you have. I had the same problem and eventually figured out its due the way the drone, transmitter and app communicate with each other. The true underlying issue is that the P3S is the only DJI drone that communicates via wifi to the camera versus Lightbridge like the rest of DJI drones which means that wifi signal can cut in and out, even for a split second, and once that happens the mission will fail, though thus far there is no function of the DD app that will tell you as much. I don’t even think DD knows this yet because I figured this out just the other day after much communication with many technicians to no avail. I had a theory of it though and after the purchase of the inspire and doing all the same procedures I did with P3S I also did with the Inspire, this time the inspire did the mission flawlessly where the P3S did not.

1 Like

Long story short, you need a device that flies via light bridge, not wifi. That, or never fly the drone far enough that the wifi could disconnect even for a second, which is about 40 yards.

this is really good feedback- thank you.

1 Like

Thank you for your help. I guessed as much as I really couldn’t see anything else I could possibly do to get a successful mission. Very strange how the drone continues to fly the planned course though…

Never mind, perhaps I will have some luck every now and then, but I will certainly stop attempting missions on a regular basis and wasting time.

Much appreciated

I have no issues with my Inspire 1’s and Phantom 4’s for what it is worth …

1 Like

Yea, Inspires, and all the Phantoms except P3S use light bridge.