2017 - Still no consistent download of map data for offline use

Really happy with Drone Deploy on so many levels which is why the disappointment is very high that I still find that despite planning a map on my desktop OR iPad, when I get out to the field and don’t have WiFi, I’m staring at a screen with no satellite base imagery (I just see the flight path). I’ve tried everything. I’ll wait while I have Internet for it to “download the latest 3 maps for offline use” and think, “Ok, this time it’s going to work”.

Nope. No maps when I’m out in the field.

Why is this so difficult to solve for?

Pixhawk has been doing this for nearly a year. Plan a map, SAVE your plan…the system simply saves the map/satellite data needed to support the mission and when you’re out in the field…that cached data is there.

PLEASE make this a high priority on features - it is a longstanding, unmet need and it’s table stakes for a drone mapping user experience.

Thanks and keep up the great work!

1 Like

This is the #1 priority for Dec. and Jan. We’ve been working on a complete overhaul of this works. It’s coming very very soon.


Good to hear something is happening at last. I’ve been reporting that this is not working since last April. Took the drone out today and it still doesn’t work - never has.

My work around was turning on mobile hotspot…then linking my “flying” tablet to it…it’s been my saving grace for a year now…

I found that the latest version of DD on iOS seems to need an internet connection before it even starts…painful if you forgot to start it before you left the office and dont have internet where you go to fly.

This shouldn’t be the case. Just ran it on my phone in airplane mode to double check and it starts up fine. What are you seeing?

On the test that I tried I had 2 issues. Firstly, the app logged me in but didnt show me any of my flights.
The previous time it sat at the login screen and just spun.
I have just done a test in the office in airplane mode and it works - so its either buggy or I am doing something wrong.

Hey, we have just released an update on ios, soon android will follow, of our offline mode. Try out the latest app 2.0.29 and turn on “available offline” for the plans you wish to fly offline. This will only be visible when viewing the plan on your phone.

Thanks for the update chasemgray - I’ll be sure to give it a go !

Can anyone help me out? I’ve recently tried to use DD app with my Phantom 3 4K on IOS device. Everything is up to date but when I do the preflight checklist everything checks out except controller switch in correct mode ( I have it in F mode before I even launch app) and uploading waypoints. I’ve waited patiently for about 10 minutes on each of the 5 attempts I’ve tried and nothing has changed. Any advice?

Hi, I replied in your other thread. Please try to keep the threads on topic. This post is about using Dronedeploy while offline.

Chasemgray - just some positive feedback. I did two “offline” flights today and they worked a treat. Exactly what I needed when I am in the middle of nowhere. Thanks.

Same here Chase - I have now done a couple of flights using the new OFFLINE feature - worked like a charm. This is…AWESOME!!!

Running app version 2.0.42 the last 2 days I’ve had to have my hotspot feature on with my iPhone to be able to fly with my iPad. If I didn’t it would just sit there trying to download the map. I have planned the flights on the iPad and switched the button for offline map and I’m not having success. In fact today, my last flight when it was about 80 degrees out I couldn’t get my hotspot to connect from the iPad and ended up flying from the phone. I’m glad the missions sync across devices otherwise I would have been stuck. I’m flying a P3P. These are they first 2 days of my trial and I’m finding more things I don’t like than do like at this point.

I think I have the off-line map working finally but today a related problem cropped up. The mission/map was shown correctly but when I tapped on the airplane the mission changed to a much smaller area than I had saved with no explanation. Had to leave the jobsite empty handed. Any ideas?