Unlocked Area

#1

What is the best means (process or flow) to conduct DD mission when in an area that DJI Requires unlock? I have appropriate approvals, DJI Cert installed an activated … Yet DD ascends to altitude and pauses. Shutdown DD app, open DJI reactivate authorization, shutdown DJI APP, then reinitiate DD (or continue) and it seems to work. Is that the best way? Is there instructions to follow? Search of the topic listes a link from a DD ADMIN, but link 404s.

1 Like
#2

I have experienced the same thing even though I had my waiver, DJI unlocked and an Air Map LAANC approval. I think the standard answer is that it is not consistently working in DroneDeploy.

2 Likes
#3

Make sure you Force Stop the DJI App, closing it doesn’t really close it. I’ve flown within restricted airspace (with Tower Approval) and DD never had any issues.

Here’s a check you can do. Check your DJI Max Altitude setting and compare it to the DD Flight elevation. If the DJI is below the DD then possibly the DJI App is still running in the background and causing an issue. DD hooks into the DJI API (Application Programming Interface) and issues commands to the DJI SDK (Software Developer Kit) to perform some task, like start motors, set altitude, go to x,y,z location, take photo etc etc. As far as I know they don’t invoke the DJI Flight Restriction code to prevent a flight.

3 Likes
#4

Good tips. I’m not sure how to force close on the iPad besides swiping it off and my altitudes are set at the legal limit in DJI, but I will verify all that.

1 Like
#5

Yeah on the iPad stuff I go in and do the swipe off the list, I’m guessing it closes it. On Androids you can close and app but its still running in the background until you Force Stop it, its a speed load thing but eats up a lot of memory/cpu and slows the hone/tablet down. I read a long time ago to make sure you unload DJI when running 3rd party software so as a developer that means remove out of memory lol.

2 Likes
#6

I’ll give it a go . . . thx GregO ~

1 Like
#7

Hey Guys,

Yep, unfortunately we cannot guarantee that you will be able to fly with the DroneDeploy app in NFZs due to technical limitations with DJI’s Software Development Kit (SDK), which DroneDeploy is built on. As a result, we may not be able to execute the flight. We have had a few customers follow some instructions that has worked for some(hasn’t worked for all) to unlock in the DJI Go app.

You will need to complete the following steps in your DJI account, and make sure to read this documentation on the DJI website(https://www.dji.com/flysafe/self-unlock).

1.Open the DJI GO app.
2. GEO popup will appear.
3. Log into your DJI account.
4. Press the I agree to GEO terms, tick the boxes for I have permission to fly.
5. Verify with a text message.
6. You should get confirmation.
7. Close the DJI GO app.
8. Plan your flight on DD.
9. Press take off in DD.

If you are unable to fly with the DroneDeploy app after completing these DJI steps, we recommend using DJI GS Pro app (free for iOS users) to plan and fly your waypoint mission.

1 Like
#8

Correct, this is the workflow that I have been following. What do we need to do to fix it. Why is it that Litchi, SiteScan and AutoPilot don’t have any problems with this? I assume that DroneDeploy has someone that they are tight with that can get a fix in the works?

#9

DJI should have a GEONFZ API (or whatever they call it) call that allows dev’s to call that routine passing whatever parameters needed to trigger DJI to accept the user’s agreement to fly with proper authority. If they don’t then that’s a major flaw in DJI’s SDK.

DJI may have a GEONFZCheck (or whatever they call it) routine that DD must call first to determine if the mission is going to be flown in a NFZ area.

Time to research DJI SDK.

1 Like
#10

Here is a quick DJI SDK GEO search:

This is a demo
https://developer.dji.com/cn/mobile-sdk/documentation/android-tutorials/GEODemo.html

This shows how to do it all from a quick cursory look.

2 Likes
#11

I was pretty close, lol

getFlyZoneManager().unlockFlyZones(unlockFlyZoneIds, new CommonCallbacks.CompletionCallback()

#12

KB — I may not have structured the issue correctly with the info you replied back with (9-steps). The work around ‘seems’ to be working . . . (all apps closed after flying via GO4) Open DD get to ‘FLY’ button . . . stop mission, close APP, open GO4 verify the GEO Fence toggle is ‘ON’ in GO4, close DJI, open DD, then FLY mission. Makes absolutely no sense why it works that way, but its the only thing that has allowed the flight so far. Bad thing is, its a 2 battery flight, so I have to go through the same procedure the 2d time. Without those steps, all indications are that the flight will be allowed . . . aircraft climbs to 194’, then just sits there. I’m flying this job through next FEB and happy to ‘test’ any procedures your engineer’s come up with.

#13

I understood the work around. I was just looking up the DJI SDK code that could be used in DD (if it’s not already in there) so you wouldn’t have to go in and out different apps. There is no reason (unless DJI hasn’t fully supported the NFZ in the SDK) that a 3rd Party app couldn’t GEO Unlock from within it’s own app. So once you GEO unlocked that area it stays unlock during the time-frame, that way if it’s a multiple battery you don’t have to re-unlock on each battery.

I’m assuming that the DD developers already know this info and either it’s a DJI SDK bug, DD Bug or DD hasnn;t fully implemented it yet.

#14

gotcha . . . ya, my reply was to KB. Your analysis makes total sense. If I were a betting man, they don’t have many issues reported like this, so it may get ‘listed’, but chances of someeone actioning a solution I suspect are low. The ‘crappy thing’ about this is DJIs GEO-Fence is wrong . . .the area is a temporary Class D and when the tower closes its G . . .but NOT in the frickin’ app !! (for the record I’m anti- GEOFence ~

#15

I totally agree that the DJI apps are crap. I’m a 107 pilot and I call control towers to get clearance if I’m in controlled airspace. DJI app doesn’t know that and to request a GEO unlock is not good since as you say the airspace can change depending on tower status.

I do a LAANC request on all my flights even in G air space, doesn’t cost me any money and it’s less than a min of clicking. I have no issue letting folks know I’m here. Since I fly in Houston and I’m also a firefighter, I deal with Life Flight helicopters, here they fly between 400 and 500 feet and they go any where, they are not required to fly certain routes. This is why I do the LAANC because the towers they talk too know I’m out there and can inform them of my location.

Screenshot_20190316-130914
This was a G airspace flight with LAANC request, that plane flew around me since I notified the FAA where I was at.

Now back on topic lol

DD will add/fix this because it will only help their product in the long run. Also users in here that are Business accounts will request/push for issues to be fixed.

You can send a email to support@dronedeploy.com as well to ensure they get it on the books. DD employees monitor the forums all the time but things could slip through the cracks

1 Like
#16

Just LAANC and calling the tower is no longer an option at ABIA. I flew there 4 times that way and all of the sudden started getting denied. I was told to go through DroneZone and still have not been able to acquire authorization. I am happy for my mates in Dallas and Houston that are still able to fly because their airspaces are horenedous.

1 Like