Terrain follow maps with multiple batteries swaps

We are trying to use terrain follow in mountainous terrain. The flight is 200 acres. There is cell service. The terrain follow works great following at 300’. The problems we have are when we stop the flight mid way (either flick the remote to sport mode or press return home on the app interface) to land for a battery swap. The app prompts to reset flight or resume incomplete mission. We resume. The drone is sent to the original starting point location and elevation then continues to re map what was just done. We tried restarting all equipment involved in different sequences trying to resume mission multiple times. Still no luck.
Also the map on the drone deploy interface is lagging heavily to the point where you don’t know where on the map your drone has completed/amount left to go. Even the battery life on app interface is lagging(ie: remote reads 59% app reads 75%).
The map is also not fully loading the grid lines on the device of the actual flight made on the desktop. All the grid lines are showing on my device prior to connecting to the drone but as soon as we connect drone and enter the flight the grid lines are only showing in blue and only the first 8 or so passes( about 25 passes are supposed to be showing).
Prior flights we have done just fine with battery swaps but that was before terrain awareness has been available.
Anyone had these problems yet?

1 Like

Just to note we are using the app under the explorer version until we complete the flight.
Then we will subscribe to business version to send our photos captured and build a map.
Previously we have used the business version successfully but that was before terrain follow was available. Not sure if terrain follow is the culprit. The drone just isn’t being told to go back to where it left off.

1 Like

It sounds like it is completely forgetting where it was and is acting like the DroneDeploy app had been rebooted rather than going through the designed workflow and continue mission prompts.

What version of DroneDeploy is installed, device model and device OS version?

Hi. Thanks for the reply. iPhone 6s Plus running 13.3.1 iOS.
Mavic pro is the drone being used.
Drone deploy version 4.2.0


We spent 4 hours trying different sequences this morning. It sometimes would stall out on the drone deploy checklist stage just before takeoff at camera and flight plan pre flight checklists. Sometimes it would pass(only after a minute or so of waiting). Other times it would come up with an error and ask if we wanted to proceed anyways. We declined and just tried again and eventually it would work.
Ever since terrain follow I’ve noticed the battery life on the iPhone has gone downhill really fast too.
We are going to make a map of some local Nordic trails. That is the project we are working on.

1 Like

Could you update to v4.3 and give it another run? There were quite a few performance enhancements which seemed to work for me last week. If you still have issues could you please report them in this thread?

I will try that and let you know what happens. Thanks.

1 Like