Continue mission problems in 1.3.3

Today I tried 3 times to map a large area using continue mission function after a battery change. In previous versions of the app it would often leave a strip out and pickup a couple of waypoints after it left off. Today in this version it did 3 different things, but never successfully continued a mission. In all cases the portion before the battery change worked normally. The first time I brought the drone back mid-mission by first switching to P mode on the controller and flying it straight back. The next two times, I pressed the home button on the app at took over manual control by switching to P mode after the drone was descending overhead back over the home point. The missions went like this. 1st try. Changed battery, restarted app and selected my previous mission which looked normal and showed the correct point I had paused the mission on the map, after clicking “continue” it completely reoriented the grid 90 degrees from where it started with no dashed line indicating that any of the area had been flown at all. 2nd try, changed battery tried not to restart app, but that did not work, because the “older” option was not available on the right side of the screen, restarted app where it showed appropriate place I left off. After clicking the green check it took away the dashed line, left grid the same and took me back to waypoint number one. 3rd try I found the old mission, but no dashed line was present from the beginning. Hope this feedback helps. If you guys have any suggestions that will help with troubleshooting send them my way and I will try them. @chasemgray

Thanks for letting us know. Is your DroneDeploy username the same email address you’ve used to sign up to this forum? If so, I’ll look through your logs to see if I can find the issue.

I also had the same issues today trying to fly a large area. I was able to setup the boundary and start the mission with no problems. When the battery got low I pressed the home button and brought the drone back. I then changed the battery and restarted the app. I was able to select the mission and selected continue and the check button but nothing happened. It also looked like it missed where I paused the mission at. I shut the app down and restarted it and this time it went through the check list and resumed the mission but it added some strange flight lines on the end of the mission. I also experienced some issues with the app disconnecting from the drone during the first part of the flight. I have also noticed that since the last DJI firmware update the drone does not sound the same during flight. It sounds like the motors are stalling some during course corrections. This does not seem to effect the performance of the phantom and it only does this when using Drone Deploy. Thank you.

I also had no luck continuing a mission after battery change (Inspire1). Each time I pressed the home button during the mission, but when I inserted new battery and selected the old mission (which was represented correctly), nothing happened. Tried several times - no luck. Thx!

Were the flight lines that you already flew dotted? Did it ask you if you want to continue or start over?

Thanks Chase. Yes, the flight lines I had already flown were dotted. I was given a choice to continue or start-over, but nothing after that (if selecting) continue.

To give more detail, I had aborted the flight (by pressing home) at around 50% battery. I had tried this by both keeping the app ‘open’, as well as shutting down app and re-starting back up (with new battery). Both times the app started up default with a new mission, but when I selected ‘old’ missions the previous mission came up (with dotted lines), but at that stage software was not interactive any more’ after choosing ‘continue’.

Thanks for help…


Were these flights with the most recent version of the app (1.4.2)? This sounds like an issue we had previously.

I’m wondering if there was ever a solution to this issue. I’m having the same problem.

We did resolve these issues. Are you using the latest version of the app?

Yes I’m using the latest version on iOS. I didn’t see this thread earlier so I started a new one, just FYI.