DroneDeploy App Version 4.3 Bugs

I have been running (or flying) into an issue when using DroneDeploy Version Mobile 4.3.0 during Panorama missions. I only experienced this issue occasionally a few months ago, but now it seems as though 90% of panorama missions run into this issue.

When I initiate the checklist right before launching a mission, the way point that is set in the distance for the panorama flight will shift to the home point (take off location).

The normal course of action usually have to take is rather tedious and convoluted:

  1. Exit the pre-flight checklists, and re-initiate the pre-flight checklists. Still encounter the way point issue.
  2. Shut down the DroneDeploy app, restart app, restart checklists. Still encounter the way point issue.
  3. Make copy of panorama flight plan in the same mission, initiate pre-flight checklists. Still encounter the way point issue.
  4. Create brand new mission, create new panorama flight plan trying to mimic the original panorama flight plan. Initiate pre-flight checklists. Still encounter the way point issue.
  5. Shut down the DroneDeploy app, restart the app, re-initiate the pre-flight checklists. Sometimes this will do the trick and I will be able to fly the panorama mission as planned.

If the mission is not functioning as planned after step 5, I usually have to create yet another blank project and try and recreate the panorama mission within the new project. If that continues to not solve the problem, I rinse and repeat the above steps until I can strong arm the app into working.

We’ve had a few hiccups with other older projects when trying to fly, which leads to me to believe that the older a project get, the more prone it is to experiencing issues when initiating a flight. However for panoramas, we have been experiencing the above issue no matter the age of the project.

I am posting here to see if anyone else is experiencing this issue, and if there is anything I can do to smooth out this process.

Running DroneDeploy on iOS 13.3.1. Hardware is an 11" iPad Pro.


Hey @AlexanderBP, great detail. Is this when starting the mission from the ground at home or are you already in the air. I am usually finishing another mission by the time I get to pano’s so I typically fly to where I want it, restart DroneDeploy and then open the mission. Basically I am just trying to emulate daisy-chaining missions since that hasn’t been released yet. That said, I have had a couple of occasions where I was doing multiple pano’s and the next position would try to fly back to the previous position. Different, but similar. Sounds like it is just not setting a new waypoint. Could you please email support so we can get good coverage? I will try to repeat the behaviour on my next flight, but I am in a P4P.

1 Like

Hi there @MichaelL! This is Alex from Pflugerville.

We run into this issue at every point of the mission. Whether its just firing up the app first thing in the morning, after finishing a mapping mission, or even after a manual flight in the DJI GO 4 App. We have yet to try doing the manual daisy-chaining of missions, I am excited to give that a shot, whether by hand or waiting for the upcoming DroneDeploy release.

So if I understood correctly, you fly the drone to the pano point, hover it, restart the DroneDeploy app whilst the drone is hovering in the air, and initiate the pano mission?

Thank you for the information Michael, I’ll give support a shout.

1 Like

Oh, that Alex! Correct. My typical workflow is - Initial takeoff and fly the map. If I have battery left and depending on how much I will switch to S-Mode, back to P-Mode, reboot DD while still in the air and select the next mission. I try to plan my missions so that the ending waypoint of the last flight is very close to the first waypoint of the next. Basically just doing a 180 on the best alignment if needed. Like I said before, I am in a P4P so we may being seeing some different behaviors between the new app and the Mavic. We needed to start a new thread for v4.3 specifically so I will edit this title and pin it.

1 Like

Nervous as I get ready for bed this evening. Been worrying all afternoon actually. First DD flight in 3 months tomorrow morning. First DD mission since it all went downhill in December and likely to be a deciding factor whether or not we renew our subscription next month. There’s a break between the storms so going to make the most of it. Eight batteries charged.

Fail? Flyaway? Tablet overheat? Short tablet battery life? Lag? Perfectly working with no mishaps?

What’s to expect? Running 4.3 with latest iOS on Pad Pro 2017.

1 Like

I have run two missions without any fail. One of them being a 3 battery mission. I will disclaim that I moved to an iPad Mini 5 and recently got a P4P V2.0, but everything was butter smooth.


Well, I guess I spoke too soon. @Andrew_Fraser. Last mission of the day and everything was going great until I noticed there wasn’t any telemetry on the bottom…

@Andrew_Fraser, I had mixed results today, mostly good but ended very disappointing.

The app loaded into Classic View quickly and I was able to move through the menus okay. It seemed a bit sluggish, but not horrendous.

Getting going was fine. Took off in Go4, closed down, switched to DD and started the mission. The location of the drone on the app lagged for about the first 20-30 seconds after each take-off (updating every 4-5 seconds) but was smooth for the remainder of that battery.

The first hurdle I came up against, was when continuing the mission after the first battery change, when the remainder of the plan failed to upload to the drone since it considered “2 waypoints were too close together”. Not sure why as it was quite happy to start the mission at the beginning, but forced me to quickly (drone in the sky) reset the mission and make quick modifications to continue from were it left off. Managed that and moved on, wasting about 15% of a battery.

Automatic exposure settings were all over the place. Some images were blown out and others were dark. Conditions weren’t great as it was blue sky in early March and the site was surrounded by deciduous trees, so this was to be expected I suppose.

What messed it up for me and is a show-stopper, was that of the eight batteries I intended to use, and comfortably got through a month or two before Christmas, was that the tablet battery was exhausted after three and a half drone batteries. This is a big problem for me. The tablet wasn’t at all warm, like it was in December and I had to abandon the mission before getting a sufficient number of images to process an accurate map. I only had 1% battery left when I landed. The genuine battery in the tablet (fitted by Apple) is less than a year old and copes well with any other app (9 hours of use perhaps?), so it appears DroneDeploy is still drawing a massive amount of resources from the tablet.

I honestly don’t know what we’re going to do. It’s a great shame, but if I am no longer able to continue with what I’ve been doing perfectly well for the past 2.5 years, I think I might have to call it a day. I can’t afford to upgrade the Pad on an annual basis. In my opinion, the basic app has simply been spoilt with all of the new features they’re trying to load it up with. I can understand the desire to, but it shouldn’t be at the detriment of what it used to do extremely well.

Edit: Notice that the LiveMap I was emailed about does not appear in the ‘Explore’ tab of the Project. Also, since I had to reset the mission, I’m assuming is why the fact that I flew it doesn’t appear on the Desktop - no flight record and no ability to upload, other than to upload manually. All odd since I can view the LiveMap if I click on the link within the email I received, but no evidence of it directly through the webpage or app.


Experiencing the same issues in a different way. I haven’t flown a Pano since last month due to weather, but this is what I was getting: After going through the checklist for a Pano it would give me an error and tell me that the waypoints could not be loaded! Shut down app and reopened…same thing. Shut down app, tablet, drone and controller, turned tablet on, controller, then drone and opened up app and still errors! The only way I could get it to work was to copy the Pano mission and it would work flawlessly! I could fly the mission, land and try again only to get errors! The only way I could fly a pano mission was to copy it and then fly it! Also can not get a live camera feed after the first mission unless I shut down EVERYTHING and then turn it back on…that’s why I tried that sequence for the pano! DD needs to get it together. It’s getting worse instead of better!!!

1 Like

Had the opportunity to fly a few hundred acres (like about 1500 acres) mostly ag land the past few days, with the latest DD version 4.3., and 4.3.1. Mostly positive. Had no issues with PIP. Battery status indicator good. The problem I had is that I lost my map on every battery swap, so I could not see my map status for the rest of the mission. Also continue to have loss of GPS notifications on most completed mission landings, but usually lands fine.

That being said, There is also an area that I fly in that apparently has some connectivity problems, especially during landing ops. The drone seems to lose its mind and becomes very hard to control, even when switching to manual control. Sort of a Bermuda Triangle thing. LOL.

IPad Mini 4, OS 13.3.1

1 Like

Yes. I had that problem too for one flight.

1 Like

Yes. That problem I had also. I would fly the first pano at 150’ and it complete just fine. When I flew the second pano mission at 75’, same location, the drone would not travel to the same spot, but instead took the pano shots directly overhead. This happened several times.

1 Like

@MichaelL We’ve identified the source of the shifting panorama and photo waypoints. Essentially, when flying multiple plans the drone can get into a confused state where it doesn’t fully clean out the last mission’s waypoints. You’ll see a fix for that in version 4.4.

@JamesC Noted on your thermal experience. We’re planning to kickoff additional performance related work in Q2. Recent performance work has made a noticeable improvement for most people. Appreciate your patience as we improve.

1 Like

Thanks @Andrew_Fraser.

No paid-for app should be struggling like this, least of all those whose subscriptions start north of £1,000 per year. I’m surprised following each update, that we encounter one bug after another, and before those are ironed out, new ones are introduced when new and exciting features are added. Are they not tested? Despite multiple promises and assurances that things will improve on each update to follow, we’re just going from bad to worse. The last version number of the app to work efficiently and correctly, started with a ‘3’ I think and that was what, 4-5 months ago??

Surely it makes good business sense to first have a good, solid, firm app we can rely on before trying to improve on features? That’s what’s killed it here. Albeit not perfect, we did at least have an app that was consistent and 98% reliable. All of the problems we face now are following your attempt to incorporate new features and they should have gone through sufficient testing before releasing. The basic app has become bloated with so many good ideas, all but the latest hardware can cope with it. And even those that can cope performance-wise, struggle with other non-performance related bugs. It’s almost like buying a Samsung or HTC 5-10 years ago, or some might say, now!

Due to issues many faced with your app and older models of hardware they had a couple of years ago, much older, I bought what was the state-of-the-art iPad at the time. It was an awful lot of money and bought at your recommendation, only 18 months later, it appears in order to continue using your app now, I might have to upgrade? Again? Seriously?? Just to complete a mission and all because the app has been stacked with features some will never use, or want. I just want what I had back. Everything worked!? The app did what it needed to do and it did it well, despite what your reseller said when trying to discourage me from taking a subscription and buying another that was more reliable, in their opinion.

I am pleased to hear that your office will start work to resolve the performance issues next month, but where does that leave me and several others in the meantime? Can we hope that you might now allow us access to the last reliable version whilst you fix things? This has been going on for several months and my subscription is up next month I think!? Renew but not be able to use it? How am I supposed to explain that to my employer?

@Jamespipe, I absolute love the fact that you provide a forum for us to openly discuss and share our findings, good and bad. Please listen to your customers. Please can I ask you to allow us access to the last reliable pre-bloated app? I would be grateful for a response please.


It definitely takes allot of patience. I think we all need to keep in mind how bulletproof DD was for 2-3 years previous to the v3.4 update. This was when pano, progress and video was added. We also need to recognize the complexity of this app and where they are going. There is no progress without failures and the rate that they are trying to expand there will be failures especially with the complexity and the lack of standardization of the world they are supporting. Some will say this app and that app don’t seem to be having any problems and I would say that 1) Go to their forums and see before you speak, and 2) Look at the scope of functionality and you will see that even though DD may be missing a couple of features that others may have that DD has far surpassed all the others when you look at the scale of their entire solution.

I’ve only been familiar with DD for 2.5 years, but I remember for at least the first six months, I couldn’t take a picture in focus, and when processing I was really struggling with the bowling effect. Although I still can’t rely on DD to take a picture in focus, they did incorporate a feature that would allow Go4 to take over. A big thumbs up and is when I took up the subscription. I do lose up to 10% battery on each change over, but at least it’s consistent and I know where I stand. I knew what I was buying when I took on my subscription.

The engine has also improved significantly, to the extent that I no longer see much bowling affect these days. Not much at all. The 3D display is still not something I am keen on, although it has improved slightly since it was adopted and something I’ve come to accept.

But when it comes to no longer being able to walk, whilst the developer insists its able to run, that’s when I have to stand back and ask, “Really?” I appreciate whole heartedly that progress needs to be made if they are to compete with alternatives, but maintain that it shouldn’t be at the consequence of losing what was a well-grounded app. If progress is needed, and it should be, let it be developed and experimented alongside a working app and not instead of, and certainly don’t charge your existing customers high prices for their subscription and not fulfil your end of the subscription. We’re not talking about a few minutes of inconvenience or a couple of quid here and there. The app is currently useless unless I buy another top of the range iPad that might last another 18 months, might, and even then, there’s no guarantee it will fix the problem at all. The last bought was at DD’s recommendation and bought the best available to future-proof it.

It makes sense to allow customers either or. Either use a reliable app, of which they thought they were paying for, or participate in a beta program. Or both. Is that not how developers usually improve on their apps? Not to lose all ability to provide for it’s intended purpose. My last processed map on Friday was horrendously disappointing and inaccurate. Simply for the fact that I was unable to take enough photos. Surely that should be the number one goal? Provide for what the customers are paying for?


Good stuff! I still don’t understand the app development world not offering stable and edge versions. I have done beta testing for many industries and platforms and there have always been four stages. Alpha, beta, release and stable. I will say that although I had the telemetry gltich everything was fixed in the last update. I am going to do some more testing this week with 3 different iOS devices and two Androids on the same mission and will see what we get.

The processing engine has improved, but I would almost put more weight on our experience and the more mature flight plans.

I have also done ALLOT of testing fro DroneDeploy in the past and that did not happen with v4.x.x so I am assuming it was all done in-house, which is not a good development move. If they did use customer practical testing then I would like to know who they are and how full the extent of their testing was. @Andrew_Fraser

I had the telemetry glitch the one time I used V4 before Christmas, but not last Friday. I was unfamiliar with the new version of app and to be honest, didn’t care whether or not the fancy parts worked. So long as it could perform a simple flight ie. flying up and down a ploughed field between waypoints. I don’t need it to do anymore than that. The Pad with 85% battery ran out within 35 minutes before Christmas on V4. It lasted a little under 50minutes with 99% last Friday. When on V3, I ran for 2hrs 45 minutes on one charged iPad, and still had 14% left when I landed.

I’d like to take credit for my better maps, but I don’t think I have much to do with it. Maybe a little. I do have a better understanding of what is required to produce a decent map and possibly why I plan now the way I do, but unfortunately, I no longer have sufficient battery power to so. :frowning: I have processed a couple of old jobs again though, using the original photos and have seen small improvements in the resulting map. This can only be down to an improvement in the engine.

And this might go a long way to explaining why we are where we are Michael. If only those that pull the strings can be convinced the only way of maintaining the revenue required to progess the app is to maintain a reliable product. V4 looks very fancy and I’m sure it will be very good when it’s ready, but it’s not and is causing me and several others a heap of grief. Other than your telemetry issue, you were okay. Other than my battery issue, I was okay. I could manage. But if can no longer fly the simplest of simplest ploughed fields anymore, then someone needs to wake up and question what on Earth they’re doing. I’ve never known another company or operation like it.

Maybe your battery was okay because you were on a new spangly Mini5. There won’t be many using that. I’d be interested to know how you get on with your other devices though. Thank you for looking into that. I’m also wondering if I can borrow the latest Pad Pro from my mate’s daughter, but again, it would be nice to think DD could be looking into this.

From my company’s perspective, albeit a small fish I’m sure, we have invested greatly in DroneDeploy, whether it be buying the software, recommended hardware, time etc, and to now find we’re seemingly being ditched, is a bitter pill to swallow. Respectfully @Jamespipe, being patient and investing in further experimental software doesn’t cut it when answering to my Board as to why they haven’t got what they’ve paid for. They want to see results and without a working app, I can’t give it to them. Please allow us access to the last reliable version.


To let those interested know, I am now in direct contact with Kaitlin at Drone Deploy. I can’t continue my subscription with the DroneDeploy app in the state it’s in. My iPad Pro can cope with the processing the bloated V4 app is demanding, but zaps the battery in 45 minutes or so, whereas I could previously get 3 hours on V3, comfortably.

If any of you are unhappy with the current state of play in terms of the ongoing bugginess and performance related issues, I urge you to address an email to Kaitlin at support@dronedeploy.com . The last reliable version of the software was V3.something I think. Something like that. Since the release of V4, we have had nothing but problems.

Thank you.