Plan ready to go - does not recognize a connected Mavic

Summary: After planning a new flight, the DD app would not recognize that my Mavic was connected. Why not?


  • Flew this drone (Mavic Pro) for the first time at Baylands Park in Santa Clara.

  • Using the DJI GO app and my iPhone first, I was able to set up, fly, take videos/photos, and land happily. I needed to unlock the area first, as the app considered my to be in a no-fly zone.

  • Started up the DD app, centered on current location, and created a new flight plan with maybe an acre of coverage. Only the Save icon was showing. See this image as an example: .

  • Could not get the Save icon to turn into the Fly icon. Tried:

    • Restarting DD app
    • Disconnecting and reconnecting phone from controller
    • Restarting controller and drone
    • Switching to DJI Go app and Pix4D app (both worked fine)
    • (the next day, at home) flipping the Sport switch back and forth
  • The next day, well away from Baylands, I could connect, plan a flight, and fly with no problem.

DD app version 2.00-2.0.29
iOS 10.2.1

Perhaps it was because you were within the Enhanced Warning Zone for San Jose International Airport? Not saying for sure, just tossing an idea out there.

I’d guess the same thing, and that’s where I’d start looking in the code, but as it stands the message is both: a) not meaningful, and b) impossible to get around. At least in DJI Go I can click through to disable the No Fly Zone warning.

Any feedback from DroneDeploy on this one? I’d rather get this sorted out so I know what to look for and I’m not blocked from working when I get on site somewhere.